1
$\begingroup$

Wikipedia has this example of normal maps:

Wikipedia normals image

I put the normal map into Blender myself and got this:

results of trying myself

Why is there a dark ridge around the edge of each shape? Based on the specularities around the edge of the donut, it looks to me like Blender is "overcompensating" every bump by surrounding it with a ditch (and vice versa). How do I stop this behaviour to get the correct edges?

(This is a minimal example of the more complex problem I'm facing.)

EDIT: These are the exact steps I took to reproduce:

  1. Open Blender 2.79b.
  2. UV map the default cube to this image.
  3. Alter the default material's "Tex" texture so that instead of Color 1.0, it influences Normal 1.0. (No nodes are involved.)

enter image description here

That's all. I have tried changing the Color Space, but like all other times I've tried, changing it has no effect.

$\endgroup$
  • $\begingroup$ Did you set the images as non color? $\endgroup$ – susu Jul 19 at 21:27
  • 2
    $\begingroup$ How did you add the image? I see no difference to the reference. $\endgroup$ – Leander Jul 19 at 21:33
  • $\begingroup$ I added my reproduction steps. If necessary I could save the file and upload it somewhere but I can't see it being complex enough to be worth it. $\endgroup$ – Sir Teatei Moonlight Jul 19 at 21:55
  • 1
    $\begingroup$ Sorry, I didn't expect you to use blender-internal even though you correctly tagged it. $\endgroup$ – Leander Jul 19 at 22:02
2
$\begingroup$

You must check Normal Map under the Image Sampling options of the texture.

normal map settings

Also, make sure to set the color-space to non-color data.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Curious. This checkbox gives me the correct expected result, even though I tried using it before and it didn't. Perhaps some other option in my complex usecase was interfering. I'll mark this as accepted and see if anything else pops up. $\endgroup$ – Sir Teatei Moonlight Jul 19 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.