2
$\begingroup$

I am new in a blender, So I have a problem. I created photo scanned texture with normal and bump map (8K res)in photoshop. When I applied it on the object, all looks good in material preview mode, but when I render it in cycles render my roughness missing. I know that I do mistake in nodes, but I can not find it. I search for it on google, Also read and watch about procedural PBR on youtube and google. But can't find my mistake.

enter image description here

Material Preview: enter image description here

Rendered: enter image description here

$\endgroup$
  • $\begingroup$ is it possible to check your blend file? blend-exchange.giantcowfilms.com $\endgroup$ – Sanbaldo Jul 18 at 19:12
  • 2
    $\begingroup$ Hello :). Your Cycles Render preview shows similar result to Eevee. Are you sure you have an HDRI for render, and not just for viewport? $\endgroup$ – Jachym Michal Jul 18 at 19:22
  • $\begingroup$ @Sanbaldo This is link G-Drive, file size larger than blend-exchanges allows: drive.google.com/file/d/1epyY7EJYxJHY1HXc_atmZprgKf8gcnGp/… Thank you! $\endgroup$ – Ayaz Kerimov Jul 18 at 20:04
  • 1
    $\begingroup$ @AyazKerimov, can you open this file (it's your file simplified a little bit) --> blend-exchange.giantcowfilms.com/b/672jM0Rs, insert again your bump.tif file and be sure to check "File > External data > Automatically pack into .blend file"? I think that that the problem is that file (using a noise node, the bumps are there). Also check your rendering engine (in your file you selected eevee, while the question you posted is about cycle, so switch to cycle to be sure to have a common ground to help you) $\endgroup$ – Sanbaldo Jul 18 at 20:32
  • 1
    $\begingroup$ @AyazKerimov, in my recent experience, 2 things can make you tear your hair out regarding what you expect from Roughness: 1) You didn't use an HDRI Environment Texture in your node editor (use the dropdown for World; by default is for Object). 2) The other is that your Bump and/or Normal maps might be blowing-out the reflectivity you expect from your material. This happened to me last night. You can try decreasing the intensity of those maps. $\endgroup$ – hatinacat2000 Jul 18 at 20:51
0
$\begingroup$

First of all problem with the roughness raised because of the missing glossy map. To tell the truth, I don't have it :) So if you created your maps as me in photoshop and applied it as texture (Normal; Diffuse and the main one) always save it as tiff format (don't forget about compression when you save it). Other formats like png make less quality. Also, use RAW photos as donors of maps.

Second: if applied your hi-res texture on your object(without a glossy map) and after rendering you're found that the object looks dry ( For instance you rendered you brownie cake or donut) don't worry! You can solve this problem with MIXShader. After changes of your Principled BSDF Shade create the second one, Glossy Shader. Turn off the first one and adjust glossy shader. Then add Mixshader. Connect Glossy and Principled Shader to Mixshader and magic will happen.

In my case, I adjust bump and normal maps they blowing out my object reflectivity. It helps a lot but not as I want because of a problem with the texture source material. Second I didn't use HDRI, therefore I add it.

Thanks to everyone who helped me!!

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.