1
$\begingroup$

I have created an object with screw modifier and I try to use it with boolean modifier to cut through a cylinder, but it's not visible in Viewport shading. It is visible only in x-ray mode. It works with a cube and sphere. Where do you thing could be the problem?enter image description hereenter image description here

EDIT: There is only one cylinder as you can see here: enter image description here

$\endgroup$
7
  • $\begingroup$ you have to remove the external cyclinder $\endgroup$
    – Sanbaldo
    Commented Jul 18, 2020 at 18:47
  • $\begingroup$ There is only one cylinder there, I edited my post with screenshot for proof. $\endgroup$
    – Mar
    Commented Jul 18, 2020 at 20:24
  • $\begingroup$ I follow you instructions and my result is ok (blend-exchange.giantcowfilms.com/b/X8W8ZoLo). Can you upload your file to check it? blend-exchange.giantcowfilms.com $\endgroup$
    – Sanbaldo
    Commented Jul 18, 2020 at 20:39
  • $\begingroup$ I see yours is as it should, but this is mine - <img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=D9prPOjN" /> $\endgroup$
    – Mar
    Commented Jul 18, 2020 at 20:54
  • $\begingroup$ Hm, that's wired. For some reason the faces that end up inside the screw modified circle object are not deleted. As far as I can tell, the rest of the geometry is there and in order. (If no other solution is found or satisfactory, the faces could be deleted manually.) $\endgroup$ Commented Jul 18, 2020 at 21:28

1 Answer 1

2
$\begingroup$

I would check the face orientation of both objects. The option can be found under Viewport Overlays. If either of your models is red instead of blue, then your issue might be caused by the faces being flipped.

To fix that, go into Edit Mode and under Mesh > Normals, use the Flip button on whichever model is red.

I just saw you uploaded your blend file. You had a couple of issues happening with this project.

  1. The normals on the screw we're in fact flipped. To fix this you just had to select Flip under the modifier settings for Normals.

  2. Your screw wasn't "watertight". You had to add end caps to each end so it so there are no holes in it. To do this I had to apply the modifier then fill the ends in Edit Mode.

  3. Lastly, you needed to set the Boolean modifier to Exact instead of Fast on the cylinder.

After that it came out fine.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .