1
$\begingroup$

I tried making a normal smoke simulation with the usual domain and the generator, the smoke starts the moment i click the quick smoke but stays in the first frame, when i resize the domain, the smoke sizes up as well, and doesnt update when moving the generator, no matter what i do. anyone know how to fix this?

The Box shown in the render is another cube, i didnt edit the domain in any way besides resizing

Im using Blender 2.83, downloaded from steam

Link to render and blender file: https://drive.google.com/drive/folders/13qhZd3OP0e5x91m5dTPqKk7N3aTcjpfI?usp=sharing

quick smoke when just made

domain resized

$\endgroup$
1
  • 1
    $\begingroup$ Free bake and rebake it. $\endgroup$ Commented Jul 18, 2020 at 11:08

2 Answers 2

2
$\begingroup$

There's a known bug with current Blender versions when using a Replay Cache (in the Domain settings, the Cache -> Type -> Replay setting). See issues 77170 and 76095.

As a quick fix, you can go into the domain settings, and change just about anything (e.g., temporarily change the resolution divisions). That'll invalidate and regenerate the cache, and your smoke should start generating from the new cube position.

You could also consider switching the cache from Replay to Modular, which gives you Bake and Free buttons to allow more direct control over the cache.

$\endgroup$
1
  • $\begingroup$ For info, you don’t actually need to change the resolution setting to force a refresh - just click in the field and press Enter to accept it as it is and that is enough to invalidate the cache. $\endgroup$ Commented Jul 18, 2020 at 13:49
0
$\begingroup$

I solved my issue where I could not move my smoke around by navigating to the Physics settings of the Smoke Domain, select Fluid, scroll down to Cache, and delete the existing filepath from the textbox. I do not know what the long-term impacts will be, but this fixed my immediate problem.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .