2
$\begingroup$

I just started learning Blender today and I've encountered as an issue with rendering. When I set up my scene (which involves a cloth falling onto a sphere) and hit Ctrl+F2 to render my animation, only the first frame is rendered repeatedly, even though Blender is clearly iterating through every frame (the frame counter is going up).

On top of this, if I try to render one frame (which is not the first) specifically with F2, the first frame is rendered instead. The object to be rendered is snapped out of the camera view to the origin when rendering as well.

I am using Blender 2.83.2. Any suggestions on how to solve the issue? Perhaps I'm using the software incorrectly?

In terms of settings, I have not done any customization and I simply render my scene as-is.

$\endgroup$
  • 1
    $\begingroup$ Have you added a key frame at the start and end as well? (I used to forget doing this when I was a beginner) $\endgroup$ – user1170874 Jul 18 at 4:03
  • $\begingroup$ To be completely honest, I don't know how to do this. Is it the insert keyframe button? If so, there seem to be a ton of options (location, etc...). $\endgroup$ – Sean Xie Jul 18 at 4:16
  • $\begingroup$ So I figured out keyframes but the problem is still occuring $\endgroup$ – Sean Xie Jul 18 at 5:06
1
$\begingroup$

This is usually caused by the physic simulation that is not cached / baked.

Go to "Physics Properties" tab, then Cache, then Delete all Bakes and then Bake all dynamics. This should be enough.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you! The render works as expected now. :) $\endgroup$ – Sean Xie Jul 18 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.