Two issues have been crushing my dreams of doing literally anything related to fluid dynamics.

I am following along with this tutorial.

However, at the 2:00 mark, the instructor very casually turns an object into the fluid, but when I do exactly the same thing, nothing happens. I even went into Cache and gave the cache folder a specific folder since I recalled something about that from prior training.

What's killing me is that I have had fluid working, but I don't know what I have done - the specific steps I've taken - to turn this from object into fluid.

The second problem is one that has plagued me literally since the start of my looking into this: I can never actually see inside the region fluid-dynamics region. It's always a damned cube. I figured out I could apply a wireframe modifier to it just to see inside (in that project, I got fluid to work... somehow). But when I went to render, it was still a cube.

Anyway, if you have guidance, I would love it. I'm tired of banging my head against a wall. Here is the blend file.

Using v2.83.1 / Windows 10 64bit


1 Answer 1


The main problem is that you need to increase the "Resolution Divisions" setting for the Domain object. In newer versions of Blender (I'm using a 2.90alpha), the default looks like it's 32. In the tutorial, the default appears to be 64. It refers to the number of divisions along the longest dimension of the domain. With a tall domain and short flow (in the Z direction), there's a reasonable chance the flow will get missed entirely, and it won't generate any particles. Reset to the first frame with Shift, and then try increasing the resolution division until particles appear. (You need to reset to the first frame for this to work.)

Now, if you start the animation with Space, the particles should start moving around. If they don't, it's probably because the cache directory is bad, so blank out that cache filename and try resetting to frame 1 and replaying the animation.

Once that's working, another problem is that a Replay Cache (i.e., Cache -> Type -> Replay) is extremely flaky in current versions of Blender. You'll find that if you move participating objects (e.g., move flows and effectors) or change certain settings, stale cache information will be left in place. You might get particles sourced from the wrong place, particles exploding, particles leaking, etc. It's best to switch from Replay to Modular (which is what's ultimately used in the tutorial) so you have explicit Bake/Free buttons. Specifically, you can "Bake Data" in the Fluid -> Settings panel to generate the particles and then play the animation.

Finally, you can make your domain see-through while working on the animation by going into its "Object Properties" and selecting Viewport Display -> Display As -> Wire. This doesn't affect the render, so it will still render as a solid cube until you get the mesh simulated (see later in the tutorial). Once the mesh is baked, that mesh replaces the domain mesh in the final render.

  • $\begingroup$ Thank you very much! This was extremely clear and completely resolved this block. My takeaway is: 1) Use the Explicit Buttons for Bake 2) Make sure that I turn up my Divisions at the outset. $\endgroup$ Jul 18, 2020 at 16:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .