4
$\begingroup$

I'm trying to sculpt some stylized boulders for use in Unreal Engine. I got something I'm happy with:

Supposed to look

However, whenever there is light on them, the shadows look pretty messed up:

Shadow Jank

After digging around for clues, I found a few posts here regarding non-planar faces. I tried using Clean Up > Split Non-Planar Faces, but it really messes up the look:

Split Non-Planar Faces

As does Clean Up > Split Concave Faces

enter image description here

How might I go about fixing the faces while preserving the look?

Thanks a million in advance!! I've also uploaded the blend file in case it helps.

$\endgroup$
10
$\begingroup$

The reason this mesh has strange shading is because of the topology. enter image description here

Polygons which are made of more than 4 vertices are called ngons. These ngons are pretty extreme in your mesh as you can see. While ngons have their place (on totally planar faces) if an ngon face has even the slightest twist, then it will cause horrible shading.

This is why in 3D modelling (especially for beginners) people avoid ngons and aim to keep faces consisting of no more than 4 vertices, which are called quads.

Another way to make these kinds of stylized rocks is to add a cube. Subdivide it with constant detail and then enter sculpt mode.

With the scrape brush, you can scrape away at the faces of the heavily subdivided cube to get nice flat edges.

Once you're happy with it, you can leave sculpt mode and then add a decimate modifier and decimate the rock to reduce the polygon as much as possible (lower the value in the slider to somewhere near 0.01).

The decimate modifier will retain the detail best while keeping the shading looking the best. Once you find a happy medium between detail and polygon count, you can apply the decimate modifier and move on to UV unwrapping and later texturing.

This is how I make stylized rocks.

Hope that helps! :)

I just added a rock I did just now.

https://www.dropbox.com/s/rcbo7lwoyoetbln/RockSculpting_Demo.blend?dl=0

I just rushed this so with a bit more time and effort put into it, you could get something looking nicer but hopefully it'll give you an idea of how the topology should look.

enter image description here enter image description here

$\endgroup$
2
  • $\begingroup$ Amazing, thanks so much for the detailed response!! Did you use an external application like photoshop or substance to create the rock texture after you UV unwrapped it? $\endgroup$ – Fractal Jul 18 '20 at 13:56
  • 1
    $\begingroup$ This was all done in blender. 1) I duplicated my rock, 2) then I added the decimate modifier to the duplicate. 3) Then I applied the decimate modifier and that was now my low poly. 4) After I Smart UV unwrapped it. 5) I baked the normal map from the high poly to the low poly. 6) Then I made a material on the high poly to get the colouring which was all procedural. 7) Then I baked the colour to the low poly again using a Viewer Node (Emission Shader) and setting bake output to Emit. $\endgroup$ – Mark Jackson Jul 18 '20 at 15:29
4
$\begingroup$

Janky shadows are the result of janky topology: Large N-gons with non planar faces.

enter image description here

At the time of rendering all objects get subdivided into triangles.

enter image description here

I cringe just looking at this horrible mess.

The takeaway is this: objects (yes all objects) should be created with some notion of the topology. Fixing things later is much harder and time consuming. It has been written many times in this site "topology is your object", is not something that you add at the end like icing on a cake.

So how to fix it? you need to re-topologize. There is no de-janker tool...

There are a lot of videos out in the Wild World Net detailing how to do it. Basically it comes down to creating a new object, and using the old one as reference to pin new faces, using proper quad topology.

If you want to try blender 2.9 there are new tools to make re-topology much easier.

https://www.youtube.com/watch?v=BEwEWKOH5ws

$\endgroup$
2
$\begingroup$

After looking at your uploaded file, I would say you don't have enough geometry to describe the object without having non-planar faces, and using the Split Non Planar Faces command will only produce more non-planar faces as it tries to remove the old ones. You can see this if you do the same command again, it still splits faces. What you need is more even geometry, instead of long, thin faces, or 'curvy-edged' faces where the vertices describing those points are not on a plane. First, try retopologising to get rid of those long thin triangles, then add edges across your faces to produce quads or tris that are planar. You can also experiment with the remeshing tools in the remesh section of the object data tab in the properties window. I'm curious how you ended up with that geometry, it looks you you used some non-standard workflow. Nothing wrong with a non-standard workflow, but sometimes, unless you know what you are doing, you can end up with problems like this.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.