6
$\begingroup$

I'm modeling this lamp, and when I try to make that curve, with the edge selected in the image at its center, the bevel doesn't limit itself within the other two edges at both sides, it extends as I show in the last image. Is there other easy way in wich I can do this?

I'm modeling this lamp, and when I try to make that curve, with the edge selected in the image at its center, the bevel doesn't limit itself within the other two edges at both sides, it extends as I show in the last image. Is there other easy way in wich I can do this?

$\endgroup$
  • $\begingroup$ I've taken the liberty of adding the sverchok tag, to allow for a node based solution $\endgroup$ – Strawberry Jul 16 at 11:29
  • $\begingroup$ @Strawberry Hi. If you or someone else wants to add a Sverchok answer, that's up to you, but tags are for the actual question being asked. $\endgroup$ – Ray Mairlot Jul 16 at 14:33
  • $\begingroup$ @RayMairlot The OP wants a solution; there's nothing in their question that precludes a nodes-based one. $\endgroup$ – Strawberry Jul 16 at 14:35
  • $\begingroup$ @Strawberry That's exactly what I said. But tags are to categorize the question being asked, not whatever potential techniques the answer might use. I could add an answer saying "Oh, you should actually model this with curves" but that doesn't mean the question should have the 'curves' tag. $\endgroup$ – Ray Mairlot Jul 16 at 14:39
  • $\begingroup$ @RayMairlot Sure, but the nodes people won't see it if you don't add the tag. $\endgroup$ – Strawberry Jul 16 at 18:03
15
$\begingroup$

Update to the answer below

I see actually that it has 12 sides, so create 36 segments not 24, and change your edge selections accordingly and the 'Auto Smooth' value


I'm pretty new to Blender and I had a quick go at this using a feature I learned about today "Auto Smooth".

Looking at the lampshade, it looks like it has 6 sides, so I created the UV sphere and before doing anything else at all, set the number of segments to 24. Please ignore the origin point as it's not important.

enter image description here

Then, I chose every 4th vertical edge using Alt+Left-Click for the first and Shift+Alt+Left-Click for each subsequent one.

enter image description here

Then using S and then Shift+Z so that only the x and y axes are scaled, I scaled those edges inwards toward the centre of the sphere.

enter image description here

Then I deselected them and selected each edge that was next to the edges I had just scaled:

enter image description here

And scaled them again using S and Shift+Z

enter image description here

OK. Getting close now. Go back to Object Mode and it still doesn't look quite right.

enter image description here

If I Right-Click on the sphere, and choose 'Shade-Smooth', that's no good because it smooths ALL the edges and you want to keep 6 of them sharp still. Leave the sphere smoothed at this point even though it looks wrong

I found out about Auto-Smooth and this might be what you're looking for.

Click on the Object Data tab - I'm using 2.90a, but if you're using 2.83, I think its in the same place...

enter image description here

Then click on the 'Normals' section and check the box next to 'Auto-Smooth' and I found that setting the angle value to 15.3 seems to produce what I suspect you want.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ I really enjoy these good ol' modeling answers :). $\endgroup$ – Jachym Michal Jul 16 at 10:44
  • 1
    $\begingroup$ If auto-smooth doesn't do the trick on its own, you can also mark edges as sharp. $\endgroup$ – Fax Jul 16 at 11:43
  • $\begingroup$ If you look in the image above, I began with the same procces as you. What i want is to export this mesh, so, does the smooth option work once I put this mesh out of blender?. I used subdivision surface modifier to change the mesh, but I didn´t know if I could achieve the same result with another method $\endgroup$ – Santiago Steib Jul 16 at 20:28
  • $\begingroup$ @SantiagoSteib I honestly dont know the answer as I've only ben using blender for a few weeks and haven't exported anything for external use. Sorry. $\endgroup$ – David Wilson Jul 17 at 20:06
  • $\begingroup$ yes, I don´t know how it works, but once the mesh its exported smooth shader it's still applied $\endgroup$ – Santiago Steib Jul 20 at 3:25
8
$\begingroup$

Absolutely nothing wrong with @David Wilson's answer.. this is a more Subdiv. approach..

enter image description here

Under 2 levels of subdivision..

  1. On a 36 sided UV sphere, pole vertices deleted, select every sixth longitude (select 2 edges at the right spacing, CtrlShiftNupad + to progressively select the rest, then Header > Select menu > Loops > Edge loops)
  2. CtrlB Bevel those longitudes with 2 segments
  3. AltE Extrude those bevels along their normals to form the external struts. And under O proportional editing, smooth,SShiftZ scale the longitudes midway between the struts inwards to make the dimples.
  4. CtrlR cut a ring around the poles, including the ends of the already extruded struts, and extrude that, to male a 'fitted' rim.
  5. Select the longitudes at the bottom of the dimples, and CtrlNumpad + in vertex mode expand the selection to the vertices between the struts. From the right-click menu, > Smooth those vertices. This will put a bit of 'tension' between the struts, and has a nice side-effect of creasing the fabric a little round the rim.
  6. If you want the inner struts to push those segments out again, bevel those with one segment, this time, for a softer curve, and SShiftZ scale out in XY.

enter image description here

You may not want the details here.. but it's always nice to try things a few different ways.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.