3
$\begingroup$

I have been searching for days and have not been able to find an answer to this question.

I have a simple model. A thin cube with default collision physics applied and a plain 1x1 with default cloth physics applied. I checked self collision, leaving this default too.

I get the below result only a few frames in. It is like the mesh shrinks rapidly. I have relaxed the stiffness. lowered the weight. Also rendered with out self collision fine....I can not seem to work out why this is happening.

I have a sub divide on the plain with 6 steps...! lowering decrease render time but doesn't help the shrinking.

enter image description here

$\endgroup$
3
$\begingroup$

Most likely your cloth vertices are self-colliding with their neighbours due to the Self Collision Distance being too large.

Firstly, when running a simulation always ensure the meshes are created at 'real world' scales - eg, for a bedsheet you might assume 2 metres a side (or 2 Blender Units). Ensure you Ctrl+A and 'Apply Scale' following any changes to scale - to ensure the simulation is using the correct scale.

Secondly, reduce the Self Collisions 'Distance' property. At Blender 2.83.2 this defaults to 0.015 metres (1.5cm). If your vertices are closer together you may want to reduce that value.

$\endgroup$
4
  • $\begingroup$ hello Rich Sedman, can that also solve this question? blender.stackexchange.com/questions/192115/… $\endgroup$ – Michael Ben David Oct 21 '20 at 23:59
  • 1
    $\begingroup$ Hi @Michael - yes, it does look to be a very similar issue. $\endgroup$ – Rich Sedman Oct 22 '20 at 0:04
  • $\begingroup$ and something i hate is that you cant set a lower value than 0.001 in the setting of both object and self colission distances...that you would help more rather than having to scale up the object to real scale... $\endgroup$ – Michael Ben David Oct 22 '20 at 0:26
  • 1
    $\begingroup$ It can be a bit annoying - although for the simulation to be realistic (using real world gravity, real world mass, etc) it’s kinda necessary. Also, it is to specifically simulate cloth for visual purposes and has been optimised for those scales. Using extreme values can cause internal rounding issues and so I guess it tries to limit the inputs to something that isn’t going to cause a problem. $\endgroup$ – Rich Sedman Oct 22 '20 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.