1
$\begingroup$

I made this rock model in Blender and now I want to import it into UE4. When I try to bake the normal map, I get an empty purple map and the message "baking map saved to internal image, save it externally or pack it". I'm having the same problem when I try to bake other maps as well. Does anyone know How can I solve this problem ? I want to add more details to my material but with this problem I can't do anything.

your help would be appreciated.

enter image description here

$\endgroup$
2
  • $\begingroup$ Hello :). These two things have nothing in common. Your empty normal map is caused by unchecked Active to Selected option. $\endgroup$ – Jachym Michal Aug 21 '20 at 18:41
  • $\begingroup$ Please help us keep this site organized. Ask only one question at the time. Different questions should go in different posts. $\endgroup$ – susu Aug 21 '20 at 18:48
2
$\begingroup$

Your main problem is elsewhere.

You need to check Selected to Active if you're baking from a hi-res mesh.
Otherwise you'll get an empty normal map.

  1. Select your Hi-Res mesh
  2. Select your target mesh with the image texture
  3. Check Selected to Active and hit Bake.

enter image description here

$\endgroup$
2
  • $\begingroup$ I have my high and low selected and selected to active enabled. I still get the message telling me it's saved externally. It was working fine 10 minutes ago and now it's not baking anything. $\endgroup$ – Emerald Eel Entertainment Feb 11 at 12:37
  • $\begingroup$ Hello :). It would be best to post this comment as a new question, so others can answer. You can link this thread to provide context. You can also share your .blend pasteall.org/blend $\endgroup$ – Jachym Michal Feb 11 at 13:09
1
$\begingroup$

The message "baking map saved to internal image, save it externally or pack it" means that blender has created this image but the images is not saved to a place in the computer, that's why it says save it externally as an image file, you could also "pack" it, which means that it is saved as part of the blend file. If you don't do any of this and close the program the image would be lost.

Bu default blender does not save images as part of the .blend file, it references the image files from the directory where they are stored.

As for why the maps are not working, it not sure, but I suggest checking that your object UVs are well unwrapped.

$\endgroup$
0
$\begingroup$

The blank bake is caused by either not having uvs or an object space not working (either object or tangent) maybe an unticked selected to active.

Also use cage but don't build a cage and just use the extrusion and it does it for you. Also, if this is happening with different types of maps it's probably because you didn't unwrap your low poly.

$\endgroup$
0
$\begingroup$

Check what you input in normal socket of shader node. Maybe this is the problem.

I had the same problem as you. It turned out that only one node was connected to the normal socket - Normal map. Accordingly, incorrect information is passed to the shader normal and Blender does not want to bake the normal.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.