1
$\begingroup$

I messed around with the preferences and changed various visual parameters in the 3D view port. Unfortunately I changed the color for the edge lengths and now I can't figure out which preference setting that was and I have made it difficult to see the value on the screen. I'm not interested in doing a factory reset as I have other options enabled and changed settings. You can see in the attached picture the edge length is purple and very difficult to read.
enter image description here

$\endgroup$
  • $\begingroup$ Should be somewhere in User prefs > Themes, maybe in 3d Viewport category. Or you can use MeasureIt addon to define that color for specific measurements separately in the Sidebar $\endgroup$ – Mr Zak Jul 14 at 17:48
  • $\begingroup$ Yes I was looking around the preferences but could not isolate the specific parameter to change. I need more specific guidance. Also I tried to find the Measurelt in the add on section. It’s not there. Does it have to be downloaded first? $\endgroup$ – Claus Jul 14 at 18:18
  • 1
    $\begingroup$ MeasureIt is built-in into Blender, so should be searchable. As mentioned, default edge length color should be in User Prefs > Themes tab > 3D View rollout, IIRC there should be Edge Length Text option $\endgroup$ – Mr Zak Jul 14 at 20:07
  • $\begingroup$ Thanks I found Measurelt. The edge length text option still eludes me. Appreciate the help $\endgroup$ – Claus Jul 14 at 20:37
  • $\begingroup$ Mr Zak Please write your answer up so I can mark it as the correct method. Thanks for your help got it all resolved $\endgroup$ – Claus Jul 14 at 23:27
1
$\begingroup$

Per Mr Zak who provided the answer to me in the comments above, I'm posting the problem and the solution I found via his help.

Problem: I had previously changed the colors of various elements in the 3D view port, because I wanted to print the model with the dimensions as I was going to physically build the model (At the time, I did not know I could simply change the theme to print friendly which would have been the best option). Sometime later I opened the file again to do additional work and found that I had changed the Edge Length Text to a deep purple which was not visible with the dark gray background.

Answer: Mr Zak provided two answers, which led me to how I could correct the problem.

  1. He suggested I install Measurelt an add on in the Blender program. I used the search function in the add on and typed in Measurelt, which returned zero results. Had I taken the time to type more slowly I would have seen that it popped up until the entire word was typed at which point it became zero results. Measurelt is actually located in the 3D View: Measurelt section. You don't even need to type anything in the search because it is located near the top.

  2. Changing the default colors. There are so many options that can be changed, that to the novice it is overwhelming. It was great of Mr Zak to steer me directly to the point where I needed to look "User Prefs > Themes tab > 3D ViewPort > Edge Length Text". There are two sections dealing with Edge. This option is in the second section so you have to scroll further down to see it.

A much better option to use if you don't like the colors or if you need it to be printer friendly, is to select from the preset options located at the top of the Theme Options window Theme Options. It is easy to switch back and forth between themes.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.