1
$\begingroup$

Blender newbie here.

Trying to create a simple fluid simulation in blender 2.83 but it just doesn't work.

Here's what I did.

  • Create a cube. Add fluid modifier. Set type to domain and domain type to liquid.

  • Create a sphere. Add fluid modifier, set type to flow and flow type to liquid.

After clicking the play button in timeline, nothing happens. The sphere stays where it initially was and there's no change in its geometry.

Can someone tell what exactly are you supposed to do to create a basic fluid simulation.

Thanks!

$\endgroup$
0
$\begingroup$

You are already really close to setting up a fluid simulation and have all the right steps - you're just getting caught out by the order as it's at the point where the domain is set and containing flow meshes are being initialised - so since you're creating the flow last it appears that it isn't getting linked to the domain correctly.

There are (at least) two ways of resolving this. The first is to simply switch the sequence of creating the domain and the flow - create the flow first, then position and assign the domain; the flow object should then be initialised with the fluid particles and you can run the simulation.

Alternatively, you can change the domain to object's Fluid Type to None and back to Fluid (and change Domain Type back to Liquid) - this should also re-initialise the fluid. Additionally, I've discovered that changing the cache to Final and clicking Bake also re-initializes the simulation.

$\endgroup$
3
  • $\begingroup$ This is what seems to be the case. Right after I posted this question I was able to get it to work. Its weird that this wasn't mentioned anywhere in the tutorials/documentation/videos I found that a particular order is required. $\endgroup$ – binary10 Jul 15 '20 at 4:05
  • $\begingroup$ Great. To be honest it’s probably a bug. When I get chance I’ll test it on the latest experimental build of Blender and raise a bug report if still not working. $\endgroup$ – Rich Sedman Jul 15 '20 at 5:09
  • $\begingroup$ I've tried the latest build (2.90) and that has the same issue. I've created a bug request to report this : developer.blender.org/T78936 $\endgroup$ – Rich Sedman Jul 15 '20 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.