3
$\begingroup$

Recently when I was using Blender, I accidentally did some sort of keystroke that messed up my navigation settings. The sensitivity of zooming, panning, and orbiting was knocked to almost zero, and I could not move around the scene at all. I did some research to find out how to fix it, and one thread led me to the Navigation preferences pane in Blender. However, I was only able to adjust the orbiting sensitivity, as I saw no adjustments to zoom or pan sensitivity.

Here's a screenshot of my navigation settings:

My settings for navigation in Blender

Any help would be greatly appreciated.

$\endgroup$
3
  • $\begingroup$ This might help: Hold Ctrl + Middle Mouse button to zoom more precise. And I have Alt + F assigned to "Center View to Mouse" for 3D View. (Its standard 2.7x keys, not sure if it is also assigned in 2.8x) Then you can hoover the mouse over the thing you want to edit and press Alt + F to refocus on it, and sort of reset zoom to zoom in further. $\endgroup$ – Fjoersteller Jul 13 '20 at 22:36
  • $\begingroup$ @Fjoersteller I don't know if it worked. I use a Mac, and I have tried Ctrl-Scroll and Cmd-Scroll, in both scroll directions, and literally nothing happened. Do these shortcuts zoom while scrolling, or do they adjust the sensitivity directly? $\endgroup$ – That Programmer Jack Jul 14 '20 at 19:17
  • $\begingroup$ I meant: click and hold Ctrl + click and hold Middle Mouse button, and then move the mouse to zoom. But you should check Preferences > Keymap and search for "Center View to Mouse", and bind it to key(s) if it isn't already. I think that will help you much more. Also you can switch searching between Name or Keybinding. (The latter can help you find out what keys or key-combinations do.) $\endgroup$ – Fjoersteller Jul 14 '20 at 23:27
1
$\begingroup$

The zoom and panning are relative to a "center point". Probably you change it accidentally or by pressing Shit + C (Which enables Center the cursor and frame all) and that leaves you stuck in a wrong position.

Change that option to Frame selected in the view or just press numberpad period key (.) to move the view on the currently selected object and the zoom and panning will work as it used to be.

Change View to Frame Selected .

$\endgroup$
-2
$\begingroup$

The scroll sensitivity is a windows issue, not necessarily blender. Google answered my question at the tip top of my search:

Change Mouse Scroll Speed in Windows 10 Open the Settings app. Go to Devices -> Mouse. On the right, select Multiple lines at a time under Roll the mouse wheel to scroll. Adjust the slider position to specify the number of lines between 1 to 100 lines at a time.

$\endgroup$
2
  • $\begingroup$ I'm not using Windows. I use MacOS, and I solved the issue on my own while following a course. Sorry for the ambiguity and for forgetting to specify that I have resolved the issue. $\endgroup$ – That Programmer Jack Apr 30 at 2:17
  • $\begingroup$ @ThatProgrammerJack, can you specify how were you able to solve the problem? $\endgroup$ – CoolCoder Jul 3 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.