0
$\begingroup$

Blender 2.83.2

Collections replaced Layers. Yet, Layers are still there (presumably for backwards compatibility). It seems Layers and Collections are related, e.g. Collection 1 = Layer 1, etc.

Problem 1: Whenever one press a number key by accident, all objects in Collections are unchecked (hidden). Only objects in Layer is displayed.

Problem 2: Blender does not remember what items in Collections were checked before. To display required items again, one must manually open each Collection and recheck items as needed. A tedious task, especially if Collections are nested.

Problem 3: Collections are far superior to Layers. But there seems to be no way to disable the Layers system to prevent the issues above.

Problem 4: Layer buttons does not seem to be defined in the Keymap, as if they are hard coded. If they can be shown in the Keymap, one should at least be able to prevent accidental number key presses by disabling the Layer shortcut keys.

If anyone knows of a way to disable the old Layers system, or how to disable the keyboard shortcut keys for Layers, I would love to hear about it!


Update: I installed Blender 2.83.3 when it was released. Sadly, the Layers panel was still there.

I had a number of add-ons installed which i did not need anymore, and disabled them all. To my surprise, the Layers panel disappeared in the process.

Trying to determine which one was causing the Layers panel to appear, I re-enabled all the add-ons. It did not re-appear. I'm stumped.

Anyway, I think all the major issues I raised in this thread has been resolved.

$\endgroup$
0
$\begingroup$

After some experimentation, I found that the number keys correspond with the order of the collections (from top to bottom). By dragging your most-used collections to the top of the stack, it is easy to enable/disable a collection by pressing a number key.

Sadly, I can't show a picture of the other problem here. Basically: The old Layers grid is ALSO showing on my screen, taking up space, cluttering things up. I found no way to disable/remove it. I eventually uninstalled Blender 2.83.2 and rolled back to previous versions. All of them had the same problem until I got to 2.82a, where the Layers grid is not shown.

It's not all bad. I found that 2.82a is rock solid stable, unlike the 2.83 series, which crashes a lot. I'll stick with 2.82a for now.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.