0
$\begingroup$

Using Blender 2.83 and wiggle_bones1_5_b16. I have recently rendered plenty of still-frame animations without this addon but after installing it, something has suddenly gone wrong. I want to render frames 1-24 into .png's, inside a folder with some gifs in it.

I have tried baking the keys for the addon but the same issue happens. Others are experiencing the same problem (see comments):

https://www.youtube.com/watch?v=hpQW9RQdwNA

Uninstalling the addon, restarting Blender makes rendering work again even though some new bone properties get leftover.

It does have to do with the "Wiggle Bone" addon because I was just able to render successfully after uninstalling it again (its Properties get leftover in the bones but it is ok). But after installing it again, I have the same problem.

Addon download:

https://blenderartists.org/t/wiggle-bones-a-jiggle-bone-implementation-for-2-8/1154726

$\endgroup$
  • $\begingroup$ Did you upload the right file? Nothing is animating when I move the timeline playhead. $\endgroup$ – Ray Mairlot Jul 12 at 13:57
  • $\begingroup$ Did you choose an action in the Action editor? Select the armature and choose an animation in the action editor. When you scrub the timeline, the animation is there. But it's stuck on the first frame when you say "render animation" $\endgroup$ – hatinacat2000 Jul 12 at 14:08
  • $\begingroup$ If I select action (any other than "Ref") it animates and renders too. So ... imgur.com/sSl2ZeK $\endgroup$ – vklidu Jul 12 at 17:05
  • $\begingroup$ I tried to render "Creep", "Jump", and "KO" using Render Animation. For me, it renders frame one over and over but calls it "0001", "0002", etc. Something must be wrong with my render settings. I have been around the block many times with rendering posed characters so I am perplexed. Do you know how to reset my render settings? $\endgroup$ – hatinacat2000 Jul 13 at 0:08
  • 1
    $\begingroup$ Try Spring Bone addon that i tried without issue. $\endgroup$ – vklidu Jul 13 at 6:25
0
$\begingroup$

HOW TO RENDER ANIMATION WITH WIGGLE ARMATURE:

  1. Select all bones with Wiggle settings applied and bake them in the wiggle bone properties area of the Bone tab. When you do this, that panel becomes deactivated.
  2. …however, rendering animation will still fail until you go to the armature tab, scroll to the bottom, and uncheck “Wiggle Armature”.
| improve this answer | |
$\endgroup$
0
$\begingroup$

These screenshots show what worked for me:

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.