2
$\begingroup$

So I'm really new to blender and I'm trying to get a book to catch on fire and fall over, but for some reason the domain for the smoke system is totally black. Not sure what to do or what I did. Any idea what's happening?

enter image description here

enter image description here

That's how it looks before I hit play

$\endgroup$
7
  • 1
    $\begingroup$ Possibly a hardware/driver problem? $\endgroup$
    – gandalf3
    Nov 7, 2014 at 0:44
  • $\begingroup$ I wouldn't know. Right after I hit Smoke and change it to domain in the Physics tab it becomes black... $\endgroup$
    – Dowel
    Nov 7, 2014 at 0:46
  • 1
    $\begingroup$ could you upload your .blend? $\endgroup$ Nov 7, 2014 at 2:40
  • $\begingroup$ Have you given it a material? $\endgroup$
    – PGmath
    Nov 7, 2014 at 15:11
  • $\begingroup$ @PGmath I don't think a material would make any difference in solid view.. $\endgroup$
    – gandalf3
    Nov 7, 2014 at 19:27

3 Answers 3

3
$\begingroup$

To see if it's a hardware problem, you can always create a 'Quick Effect'. If that doesn't work, then your PC hardware is having trouble rendering the smoke (but that's unlikely). If it does work, then you now have a working setup as a reference.

  1. To create a Quick Smoke, start with a new Blender file, then select the default cube.

  2. Call up the search box with Spacebarand type in 'Quick Smoke'.

  3. Press Alt+A to see the effect.

Quick effects search

$\endgroup$
1
  • $\begingroup$ Why are people giving this a thumbs up? What evidence do you have? This happens on my computer, also: the "quick smoke" option renders absolutely nothing. It only becomes a black box after fiddling around with the settings until "flow" or "effector" is selected. Domain just shows an empty box. Screwed around with this for hours. $\endgroup$ Apr 1, 2020 at 2:40
1
$\begingroup$

I just had the same problem. This Video helped me: https://youtu.be/xH0O4bMalhg?t=3m19s

The problem is that the default material of the smoke/fire domain is a Blender material, not a Cycles material. To change it to a Cycles material you have to do this:

  1. In the material settings of the domain cube click on "Use nodes"
  2. Change the material like in this image: enter image description here
$\endgroup$
-2
$\begingroup$

Solution.

AMD video cards do not support fire or smoke rendering, you will get the domain box rendered instead.

You will have to render using CPU only.

$\endgroup$
1
  • $\begingroup$ Welcome to the site. This is not a solution because as seen from OP's screenshot black box appeared in Solid shading, not in Rendered, so no rendering happened yet. $\endgroup$
    – Mr Zak
    Dec 31, 2016 at 13:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .