1
$\begingroup$

I was curious, I was installing Blender from the Manjaro repos and it never loads at startup and gives me a SIGILL. My specs are as below:

██████████████████  ████████   greg@manjaro 
██████████████████  ████████   ------------ 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Kernel: 5.7.0-3-MANJARO 
████████            ████████   Uptime: 1 day, 2 hours, 47 mins 
████████  ████████  ████████   Packages: 1745 (pacman) 
████████  ████████  ████████   Shell: fish 3.1.2 
████████  ████████  ████████   Resolution: 1920x1080, 1920x1080 
████████  ████████  ████████   DE: Xfce 
████████  ████████  ████████   WM: Xfwm4 
████████  ████████  ████████   WM Theme: Matcha-sea 
████████  ████████  ████████   Theme: Matcha-dark-sea [GTK2], Adwaita [GTK3] 
████████  ████████  ████████   Icons: Papirus-Dark-Maia [GTK2], Adwaita [GTK3] 
████████  ████████  ████████   Terminal: xfce4-terminal 
                               Terminal Font: Cascadia Mono 14 
                               CPU: AMD Phenom II X4 810 (4) @ 2.600GHz 
                               GPU: NVIDIA GeForce GTX 750 Ti 
                               Memory: 3075MiB / 16014MiB 

The error I'm receiving when trying to start blender:

greg@manjaro:~
➤ blender --factory-startup
fish: “blender --factory-startup” terminated by signal SIGILL (Illegal instruction)
greg@manjaro:~
➤ blender
fish: “blender” terminated by signal SIGILL (Illegal instruction)

Granted, my system is old, but I also downloaded a recent version of blender 2.83.2 and that one works right out of the box.

So, I'm not sure how to debug this.

$\endgroup$
3
  • $\begingroup$ Have you tried downloading straight from blender.org/download ? $\endgroup$ – Robin Betts Jul 10 '20 at 14:31
  • $\begingroup$ Don't use blender versions from repositories, they are never up to date and might not be compiled correctly. Use the version directly from blender.org $\endgroup$ – susu Jul 10 '20 at 14:50
  • $\begingroup$ Yes, the one from Blender does work, and that’s weird. Every other app from the repos is usually up to date in Manjaro. Given it’s usually is based on Arch repos. $\endgroup$ – GregTheHun Jul 10 '20 at 19:20
0
$\begingroup$

Ok, 2020-07-20 Blender update for Manjaro solved the problem.

$\endgroup$
0
$\begingroup$

The versions from repositories are not done dierctly by blender developers but by third parties.

Depending on the platform, some of them are not up to date, or might be missing features or libraries.

For a stable, up to date version download blender from

https://www.blender.org/download/

The main difference is that blender does not get "installed", but remains as a stand alone kind of app. and will not appear in the programs menu, but any respectable linux user should be able to add it to the menu with little effort.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.