15
$\begingroup$

Editing a mesh for a while I didn't notice that I created a n-gon. After adding a subsurf modifier the mesh heavily deformed, it took while until I found this:

enter image description here

Is there an easy way to select n-gons?

$\endgroup$
24
$\begingroup$

Yes.

Press 3D view > HEader > Select > Faces by Sides:

enter image description here

Then set the type to greater than and the number of vertices to 4 in the redo panel (F6 or at the bottom of the tool shelf):

enter image description here

Edit Blender 2.8

This option is now in Select > Select All by Trait > Faces by Sides Select faces by side blender 2.8

$\endgroup$
  • $\begingroup$ You have to deselect your model using "a" before you do that when you model is currently entirely selected, else the N-gons will not be visible because the model is already entirely selected. $\endgroup$ – tmighty Aug 24 '15 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.