0
$\begingroup$

I've got some very simple geometry (a cube with some extruded subdivisions). When I add a subsurf modifier to it these "wings" appear. They seem to be edges that connect vertices that weren't originally connected by edges. However, I can't select and/or delete them in any way.

How do I get rid of these?

I've checked the normals and they seem to be in order in the area that the wings appear in. Blender can't find any non-manifold geometry in the source.

Blend file: https://drive.google.com/file/d/1xLYRTWBchK3zBOWLDAxSLF-MlWVcGdpy/view?usp=sharing

with subsurf (wings)

$\endgroup$
0
$\begingroup$

Ngons (faces with more than 4 sides)

enter image description here

Join some of those vertices (manually subdivide edges where needed) so that you have at most 4 sides for each face.

You have a lot going on in this scene. Blender can highlight ngons for you.

In Edit mode, go to Select -> Select All By Trait -> Faces By Sides.

A little menu will appear in the lower-left. Choose 4 and Greater Than.

Do this with the Subdivision Surface modifier turned off, it will be easier.

Here is a .gif showing you how to isolate islands to work on (subdivision surface modifier has been turned off)

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ The ngons on the interior were indeed the problem! Thank you! I've been able to solve the issue by making an extra knife cut connecting the vertex under the wing to the bottom edge of the ngon interior face: i.ibb.co/tCtXdh2/wing-problem-solved.png $\endgroup$ – Rolf Jul 8 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.