2
$\begingroup$

Im using Cycles renderer and there is no reflection when I render the image I ve been searching for solutions but I couldnt find any, Im using Blender 2.83

This is how it looks in the viewport enter image description here

This is how it looks when I render it enter image description here

This is the material enter image description here

And these are the render settings

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Please edit your question and add an image that shows the issue, plus an image of the materials, plus an image of the render settings. With no information is hard to help $\endgroup$
    – no-can-do
    Jul 7 '20 at 15:38
  • $\begingroup$ Does this answer your question? Why does my object not show up? # cause number 12 $\endgroup$
    – susu
    Jul 8 '20 at 16:41
5
$\begingroup$

The issue is not the reflections, but the fact that they are blocked by something else. It looks like you have another object on top that is not visible in the 3d viewport but is renderable.

Those three big squares that are overlaid on the ground most likely belong to such object.

In the outliner search for objects that have been disabled for view (eye icon) but have the camera icon enabled. The camera icon determines if the object renders or not.

$\endgroup$
8
  • $\begingroup$ Okay, Its true, there were some planes on top,I removed them but the problem was still there. For the past 2 hours I ve been changing and moving everything to find where the origin of the problem was. I finally tried to use the material in another plane, and it worked! So I realized that the problem was just that for some reason the ground plane I was using wasnt rendering correctly, I ve put a new plane and now I works correctly. However, thank you very much for the help! $\endgroup$ Jul 8 '20 at 16:43
  • $\begingroup$ "For some reason" is not a good reason. There has got to be a more reasonable explanation without having to put a new plane. More information is needed to get to the bottom of this. $\endgroup$
    – susu
    Jul 8 '20 at 16:46
  • $\begingroup$ Then don't mark the question as solved if it didn't solve anything, We all can learn a lot more by getting to the bottom of this. I'm sure it is a simple fix as well. Try this: make a copy of the original file that has the problem. Remove objects that are not relevant to the issue until you are left with the problem only. Then share the file for others to inspect. $\endgroup$
    – susu
    Jul 8 '20 at 16:56
  • $\begingroup$ Okay, where can I share the file? $\endgroup$ Jul 8 '20 at 16:59
  • $\begingroup$ blend-exchange.giantcowfilms.com paste the link in the text of the question. $\endgroup$
    – susu
    Jul 8 '20 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.