1
$\begingroup$

I am having issues baking in blender. I'm new to blender so I don't know what I am doing wrong. I have the UV mesh unwrapped and a blank image-texture selected for it to bake to. But whenever I bake it, it always bake as a flat color with no shading. Also, I am only trying to bake the skin. I have tried the bake types, diffuse, normal, and combined and still have the same issue. I've also tried different setups with the nodes. I was able to get a white highlight around the islands of baked UV mesh by playing around with the nodes, however when I imported it into Unity, it showed up completely flat colored just like the ones I did before.

Rendered Image Shader nodes Baked UV map - no shading

with diffuse setting

$\endgroup$
0
$\begingroup$

Maybe you want it. qqqqqqqqqqqqq

enter image description here enter image description here

$\endgroup$
  • $\begingroup$ I tried this setting and it turned the UV mesh to be black where the flat color was, I also added a pic for the results.. $\endgroup$ – Peta C Jul 7 '20 at 21:01
  • $\begingroup$ I was able to fix the issue by first switching from the material view to the render view. From there I was able to see that the 3d object looked flat, so I moved the light source in-front of the character and played around with the nodes so that I could keep my Mtoon shader and combine it with another. After I did that the 3d model started to look shaded, so I baked it with the combine but I'm pretty sure the other settings would work too. Once I imported it in Unity, it kept the shading :-D $\endgroup$ – Peta C Jul 7 '20 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.