1
$\begingroup$

I am trying to split a cylinder in two parts with a plane being the cutting object but for some reason it doesn't work. Intersect works, and applying Difference on the plane works too but applying Difference on the cylinder to end up with half a cylinder doesn't do anything. I tried flipping normals and Moving the cutting plane in Z just in case it sat on cylinder vertices but it just doesnt work. Any idea why ?

$\endgroup$
3
$\begingroup$

One way is to use the split and vertex connect operators.

  • First step would be to use vertex connect and create two faces of the ends of the cylinder by selecting two adjacent vertices and pressing J
  • Then Simply select either the top or bottom half, and press the Y key to split.
  • Translate as desired

enter image description here

| improve this answer | |
$\endgroup$
3
$\begingroup$

Bisect -> Edge Split -> Separate by loose parts

Firstly bisect the mesh Mesh > Bisect use the tool, or pump the plane coords into operator panel.

In example below point (0, 0, 0) is on plane. Plane has normal -Y or (0, -1, 0).

enter image description here

After the bisect the cutting edges are selected, feed them into edge split.

enter image description here

Finally Select all A and separate by loose parts P By Loose Parts to have an object for each part.

Script version of this method in action https://blender.stackexchange.com/a/133258/15543

Script version of method suggested by @Michael

https://blender.stackexchange.com/a/133136/15543

| improve this answer | |
$\endgroup$
1
$\begingroup$

If I am not mistaken boolean difference requires a volume, a plane does not have volume. try extruding the cutting plane outward towards the side you want going.

| improve this answer | |
$\endgroup$
  • $\begingroup$ i did that, it does Intersect instead of Difference. I also applied Solidify to the plane again got Intersect instead of Difference. Much easier in Catia. 1 click, 2 tops. $\endgroup$ – mavish Jul 6 at 23:40
  • $\begingroup$ You have to choose the setting in the modifier. Also, I would recommend watching some tutorials. Blender is a very powerful program, like all things it takes time to learn, don't get too frustrated. $\endgroup$ – Michael Jul 6 at 23:47
  • $\begingroup$ I am choosing the setting in the modifier. Problem is i think Blender is quite user enemy instead of user friendly and that is a big minus. It's powerful once you get to learn it well i am sure, but to get there it is unnecessarily difficult. $\endgroup$ – mavish Jul 7 at 0:00
  • $\begingroup$ Don't use solidify on a cube. it makes the inside hollow and bools won't work as you expect. $\endgroup$ – Michael Jul 8 at 21:52
  • 1
    $\begingroup$ Believe it or not 2.8 is actually way more user friendly than previous versions. The problem isn't that it is unfriendly, the problem is that you have expectations on how things should work, it can be frustrating when things work differently than you expect, tasks that you expect to be easy require more effort, and the user feels less skilled. it's that perceived loss of skill that makes people upset. I went through this while learning fusion 360. A new tool makes even a master a beginner again for a while. Give yourself some time and learn the tools. Its not as bad as you think. $\endgroup$ – Michael Jul 8 at 21:58
1
$\begingroup$

I managed to split it in two by deleting the vertices I didn't want to keep.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Yes! avoid using booleans if you are learning how to model. $\endgroup$ – susu Jul 7 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.