2
$\begingroup$

I have a strange clump of pixels on a model added into some video. am experimenting with animated depth of field to get the model to defocus when the camera does, the pixels stay in focus and seem to accumulate through the short test clip they are not static they move around in the one spot on each frame. the material is trying to look like a glass ball of a solar garden light. now that I look I can see it rendered in the camera view of the viewport too both can be seen in the image. is there a cure for this?

noise clump

this is the material , the image used to map is a photo of the glass ball.

settings

fixed with help from Gordon Brinkmann.

render sample

$\endgroup$
  • 1
    $\begingroup$ samples are default 128 , I did not use any de-noising, I can try that but expect it to cause blur and not so sure that will work out because I am animating a timed blur, I was also considering adding a bit of film grain in post so more likely to just change models if it boils down to brute de-noising. I think it has to do with light transmission in the camera frame I got a lot of noise when I followed a lamp tutorial too. $\endgroup$ – Arthur Jul 6 at 8:31
  • $\begingroup$ If there's a lot of light and glass etc. in the scene, 128 are very few samples to get a good result if you don't use denoising or light clamping, disabling caustics etc. $\endgroup$ – Gordon Brinkmann Jul 6 at 9:15
2
$\begingroup$

It looks like noise from reflective or refractive caustics or something simlar. Try disabling "Reflective Caustics" and / or "Refractive Caustics" in the Caustics section under "Light Paths". If the noise disappears, try re-enabling caustics and in the "Clamping" section set a value for "Indirect Light", like 10 or 5.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks, I will render video tonight but it seems like a fix was in light paths, I tried the settings you suggested but ended up experimenting and found that setting transparency to zero looks to have cleared it up and a single frame render looks like a glass ball still. $\endgroup$ – Arthur Jul 6 at 8:55
  • 1
    $\begingroup$ Setting transparency or transmission to 0 might solve these so called "fireflies" problem, but it's not the best way if you're having transparent objects in the scene ;-) The values for clamping the indirect light were only examples, before I had the appropriate hardware to render high sample rates much faster and without denoising I usually set a value of 0.95 for clamping. $\endgroup$ – Gordon Brinkmann Jul 6 at 9:23
  • 1
    $\begingroup$ thanks this is all very helpful, I edited a sample image of the corrected render to the OP. I am just learning/refreshing on Blender so am willing to settle for just getting things to work. it was just an experiment to work at getting the graphic into the video and look quasi convincing, lol if it was a serious project I would have tried to plant some digital flowers in front of all the weeds ;-). I am very rusty/outdated on Blender but will be trying reflections and transparency sooner or later so the help is appreciated. $\endgroup$ – Arthur Jul 6 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.