1
$\begingroup$

I've been working happily with Blender all this week and last, performing hundreds of operations, many booleans, and getting good results in a rudimentary model for a small enclosure.

Today I've renamed the file to v2, and started to make a couple of changes. I'm just removing some material using a simple shape to create insets and a boolean difference operation. Suddenly, though, the 'difference' is behaving like a 'union' and vice-versa.

I thought I'd forgotten something overnight, and tried it on two other simple objects in the same design, with the same result. I then opened a new design with just two cubes and tried it there, where it works without error. Quit, back to my own design v2, and still the behavior is swapped.

I've restarted Blender a couple of times. Moving on to trying more renaming, rebooting tests etc. Is this a known issue, am I missing something obvious? Is there a work-around that someone can suggest. (I'm using ver 2.70 on Mac OS 10.8.5)

$\endgroup$
  • $\begingroup$ Another tidbit of data - I work in wireframe much of the time, but when flipping into 'solid' view, I noticed that the cubes that I was trying to boolean 'remove' from my object appear slightly darker than all the other items in my design. Clearly something I don't know about in blender, but no sure why that causes an opposite diff vs union behaviour in boolean. I created new blocks to do the subtracting, and those ones work fine, so work-around achieved. Still would like to learn what made the 'darker grey' items behave like that tho. Thx. $\endgroup$ – RossGK Nov 5 '14 at 15:43
  • $\begingroup$ Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Nov 5 '14 at 20:47
  • 1
    $\begingroup$ Slightly darker color may indicate flipped normals, make your they face the right direction. $\endgroup$ – CoDEmanX Nov 6 '14 at 0:30
  • $\begingroup$ @CoDEmanX - I tried doing some boolean operations in a fresh file with flipped normals cube and see that it didn't work - intersect does a difference. Maybe that was it. Don't know why the normals would've been flipped on just a normal cube that I was using for the operations tho'. I don't have that vers of the file anymore to upload, since I worked around the prob, and deleted the troublesome objs. :( $\endgroup$ – RossGK Nov 6 '14 at 15:04
  • $\begingroup$ Related: blender.stackexchange.com/q/27675/599 $\endgroup$ – gandalf3 Jul 17 '15 at 5:53
2
$\begingroup$

I had this exact problem about a week ago. IRC told me that the face normals on one of my objects were probably backwards. It turns out they were correct.

You can turn on the display of face normals in EDIT mode using one of the icons in the Mesh Display section of the N pop-out panel.

You can reverse the direction of the normals of the currently selected faces using the Mesh > Normals > Flip Normals operator. There are also some "smarter" operations in that same menu.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.