4
$\begingroup$

I am trying to make some eyelashes for a model but I don't want to use particles so I've resorted to using a PNG texture on a plane. However it only works in solid view. When I switch to rendered it messes it up completely.

enter image description here

I've tried messing with alpha clip/hashed or what have you and that's not worked and I am running out of ideas here. Here's a picture of the node setup I'm using.

And here is the texture I'm using.

enter image description here

I'm only using a diffuse texture because I don't know how to make opacity/alpha maps or whatever they're called.

Also sorry for bad formatting, I'm not used to this text editor. If you need me to elaborate then I will. This is all I could think of on the spot related to my problem.

$\endgroup$
7
$\begingroup$

You don't need the color as transparency, and you don't need the last set of nodes.

Why would you have black transparency? It will make it opaque.

enter image description here

The mix with a transparent shader should be at the end of the node chain.

Or you can just use the alpha input on the principled shader, as noted on the other answer.

| improve this answer | |
$\endgroup$
6
$\begingroup$

enter image description here

Do this and it should work and instead of doing it manually you can just enable the images as planes add-on and you automatically get this.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.