0
$\begingroup$

So I watched a tutorial on how to make fog and it showed just to add a volume scatter node, but when I do this nothing shows up, it's just blank. I'm basically trying to recreate the PS2 intro fog and need to be able to see it from a far distance looking downwards.

There are screenshots from my project:enter image description here

enter image description here

$\endgroup$
3
  • $\begingroup$ Are you in eevee or cycles? $\endgroup$
    – Yohello 1
    Jul 5 '20 at 16:21
  • $\begingroup$ evevee @Yohello1 $\endgroup$
    – Murth
    Jul 5 '20 at 16:22
  • $\begingroup$ Try increasing your density and see if it does anything? $\endgroup$
    – Yohello 1
    Jul 5 '20 at 16:26
0
$\begingroup$

Your scene seems to be very large. There are some things you should check / try:

  1. in the rendering "Volumetrics" tab: usually the visibility starts at 0.1m and ends at 100m - probably you got to adjust those values
  2. increase density of your Volume Scatter node
  3. you need light to make your fog visible, probably increase the light strength if you already have lights in the scene
$\endgroup$
6
  • $\begingroup$ Could i add a glow node to the fog? $\endgroup$
    – Murth
    Jul 5 '20 at 16:36
  • $\begingroup$ When I increase the density nothing happens, my end is already at 50000 for volumetrics, and I tried the light but nothing :/ $\endgroup$
    – Murth
    Jul 5 '20 at 16:37
  • $\begingroup$ His scene is fairly big but the object to which volume scatter node is applied is small $\endgroup$
    – Nxdhin2005
    Jul 5 '20 at 16:50
  • $\begingroup$ afaik you cannot add a glow node to your fog. Currently I can think of two things: The object itself could be displayed as bounds in the viewport, or it is just disabled. $\endgroup$
    – cgtinker
    Jul 5 '20 at 16:50
  • $\begingroup$ maybe just create a cube with basic dimensions and add your material to it, if everything is as described you should see the fog. Maybe the issue occurs when scaling up (at a certain point)... $\endgroup$
    – cgtinker
    Jul 5 '20 at 16:54
0
$\begingroup$

Make sure that if you are using an older version than 2.8 to check volumetrics in render properties tab and adjust the end clipping if you scene is large.

enter image description here

$\endgroup$
9
  • $\begingroup$ It doesn't give me the option to check it $\endgroup$
    – Murth
    Jul 5 '20 at 16:30
  • $\begingroup$ Then you must be using newer blender version .It is enabled by default.Make sure your volumetrics settings are same as mine.If still the problem persist share your .blend file $\endgroup$
    – Nxdhin2005
    Jul 5 '20 at 16:37
  • $\begingroup$ How do I share the file? $\endgroup$
    – Murth
    Jul 5 '20 at 16:40
  • $\begingroup$ blend-exchange.giantcowfilms.com -use this to share you file.Also try tweaking the strength if your lights $\endgroup$
    – Nxdhin2005
    Jul 5 '20 at 16:45
  • $\begingroup$ I tried to upload it? Im not sure if it worked. Yea I checked the cube and it just straight up disappears/ becomes see through. @nxdhin2005 $\endgroup$
    – Murth
    Jul 5 '20 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.