0
$\begingroup$

I followed Royal Skies' rigging/weight painting tutorial to get this far but when I try to move the bones in pose mode only the ones that aren't directly connected to the tail of another bone are able to move, the rest are only able to rotate. I know this has been asked many times but i've been looking through the answers for the whole day and none of the solutions seem to work for me.

I've tried both painting the weights myself and automatic weights and neither works. Auto IK is off. Location isn't locked, its simply greyed out for the bones that can't move.

Another thing is that the bones don't follow the mesh, as can be seen from the screenshot below.

And finally using CTRL-ALT-S to scale the bones in place doesn't work. I can see the numbers increasing or decreasing, and I can change them in the little box at the botttom left but absolutely nothing happens.

Thanks in advance

Blend file:

enter image description here

$\endgroup$
  • $\begingroup$ Hello, please share your file: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Jul 4 at 11:15
  • $\begingroup$ I added the file already right after I posted, is it visible to you? $\endgroup$ – Mark C Jul 4 at 14:12
1
$\begingroup$

Apply the rotation of your mesh (CtrlA) and reparent it to the armature, it should work.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Just tried that, nothings seems to have changed. $\endgroup$ – Mark C Jul 5 at 6:52
  • $\begingroup$ it works fine on my computer, please apply the rotation of your object and share this second file $\endgroup$ – moonboots Jul 5 at 7:03
  • $\begingroup$ I decided to start from scratch so I created a new file, and for whatever reason the obj gets auto rotated when importing so I applied all transforms before starting and now the armature follows the mesh properly, but I still am unable to move certain bones or scale it using CTRL-ALT-S. I've shared the new file in the post $\endgroup$ – Mark C Jul 5 at 7:39
  • $\begingroup$ all bones seem to work. Also, Ctrl Alt S is when you choose to display your armature as b-bones instead of octahedral, in the Properties panel > Object Data > Viewport Display $\endgroup$ – moonboots Jul 5 at 7:49
  • $\begingroup$ Ah I see what you mean now. Thanks for the help! $\endgroup$ – Mark C Jul 5 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.