0
$\begingroup$

I am trying to make a Text mesh, but the normals aren't coming out right no matter how I recalculate them.

Here is an image of my issue after converting to a mesh (and before): enter image description here

It just isn't smooth. I tried auto-smooth, i tried recalculating normal's, i tried smooth shading, i even tried remesh + decimation. It looks the same or worse. Adding more segments to the bevel makes it look better but doesn't fix the underlying issue. Anyway to interpolate the normal's of the vertices the way I want?

Thanks

$\endgroup$
  • 1
    $\begingroup$ Hello :). What's so bad about those normals? There's a sharp 1-segment bevel; if you want the edges round, add more segments. $\endgroup$ – Jachym Michal Jul 4 at 9:09
  • 1
    $\begingroup$ In addition to what Jachym Michal commented, the extruded part of text is actually not connected to the flat characters. So you would want to merge the vertices by distance 0 or so first before trying to smooth shade the text. I would recommend going with the bevel option though, because the geometry of text is typically a mess. $\endgroup$ – Splize Jul 4 at 15:40
  • $\begingroup$ Thank you. Merging the vertices worked!. I didn't know extruded text geometry behaved like that. $\endgroup$ – Painguy Jul 11 at 2:04
0
$\begingroup$

Splize's answer worked. Simply merge vertices of the extruded text geometry since the caps are separate from the extruded geometry. Smooth as butter and with 0 bevel segments! enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.