2
$\begingroup$

I am trying to overlay some images onto a video at certain times. When I watch the preview the images are showing up at the right time, but after rendering the images are appearing before they are supposed to. There is still a pause between images being shown, but they start to appear too early. It gets worse as the video goes on. Is there a way to sync up the images to the timeline? I'm trying to avoid offsetting the images in the timeline to account for the offset during rendering.

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
5
  • $\begingroup$ Is the original video at the same framerate as the project? $\endgroup$
    – susu
    Commented Jul 3, 2020 at 22:48
  • 1
    $\begingroup$ @susu It's 35.99 frames/second. I just added am image with more information about the source video. The project was set to 29.97fps. I'm trying out a rendering with the frames synced at the same speed. $\endgroup$
    – sissonb
    Commented Jul 3, 2020 at 22:53
  • $\begingroup$ @susu The render is still out of sync with the timeline when I changed the project's frame rate to 36fps. $\endgroup$
    – sissonb
    Commented Jul 3, 2020 at 22:58
  • 1
    $\begingroup$ Related: Can Blender VSE sync the video and audion with vfr strips? $\endgroup$
    – susu
    Commented Jul 4, 2020 at 0:46
  • 1
    $\begingroup$ blender.stackexchange.com/questions/80052/… $\endgroup$
    – susu
    Commented Jul 4, 2020 at 0:48

1 Answer 1

3
$\begingroup$

Too bad you have spent all this time on something that blender is not good at.

Here's the issue: the framerate reported is a non standard one (let me guess, the video file is a recording of some game or online video, or video from an android phone).

Some software recorders put out a variable framerate to make the file smaller and not to choke the computer for other apps.

But blender cannot deal with video files created like that correctly, as it needs each frame at the same timebase (framerate).

You would need to transcode the video into a stable framerate that matches that of your desired output so that blender can deal with it correctly.

It is not popular in this site when someone says that the VSE in blender is not a robust tool, but what you are experiencing is the result of that.

So you have two choices: conform your video to a single stable framerate, or use a different video app that can handle your file as is.

$\endgroup$
1
  • 1
    $\begingroup$ I am using the built-in screen recorder on Windows to record a video of an application. I took the raw video and imported it into OpenShot and then exported it. I replaced the raw video in Blender with the new video and the render synced up perfectly. Thanks for your help! $\endgroup$
    – sissonb
    Commented Jul 4, 2020 at 1:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .