3
$\begingroup$

Is there a way to move a vertex along an axis for it to then stop when it reaches the angled edge and snap to it. When I try to using the snap tool, the vertex just goes past or does't reach the edge as my cursor slides up and down the angled edge.

$\endgroup$
  • $\begingroup$ Hello :). Please add an example image. Also, what tool are you using to slide the vertex? $\endgroup$ – Jachym Michal Jul 2 at 17:38
  • $\begingroup$ Good idea, and I'm just selecting them and grabing them. But it'd be nice if there was a way to use the snap tool while scaling. $\endgroup$ – Luka Jul 2 at 20:34
  • $\begingroup$ Hi! I just tried it. Edge snapping works just as expected. If you constrain it to an axis and snap to an edge, it is no problem. It looks a bit like you're trying to snap the vertex directly onto the edge. For that you might consider locking the one axis you don't want to move in. E.g. Enable Snapping, press G, then Shift + X. This will let you move the vertex in the YZ Plane and allow you to snap directly to the Edge. $\endgroup$ – michaelh Jul 3 at 10:43
  • $\begingroup$ @michaelh Feel free to post a full answer, if you have a better solution :). I'd love to know, this is more of a workaround. $\endgroup$ – Jachym Michal Jul 4 at 11:10
  • $\begingroup$ I guess, what I tried worked accidentally. Sorry about that. I can see the problem now. It also behaves very differently when comparing 2.83 with 2.90(alpha). I have a rather simple solution for Blender 2.90. I'll post an answer with it. I'm wondering if this should be reported as a bug. $\endgroup$ – michaelh Jul 4 at 18:47
4
$\begingroup$

This can't be done with current snapping tools. You need a vertex in the intersection

  1. Enable TinyCAD addon
  2. Select both intersected edges > RMB > TinyCAD > Vertex at intersection
  3. Snap to the new vertex

enter image description here

| improve this answer | |
$\endgroup$
0
$\begingroup$

Here is a quick way of doing it with Blender 2.90, (currently in alpha).

We have 3 dimensions to work with, but only want to move the vertex in one of them. To solve this, we can lock one of the undesired axes and restore another.

The gif should explain it better. - In this example, I want to move the vertex only along the Y axis and have it stop where it vertically (along Z) aligns with the edge.

  1. Make sure snapping is set to Edge and enabled.
  2. Copy the z position of the vertex, by hovering over the value and pressing CTRL + C.
  3. Move the vertex by using the Gizmo as shown, or by pressing G, Shift + X and snap it to the edge.
  4. Paste the copied value back into the field.

Snapping

UPDATE

In case the diagonal edge is already intersecting with the local axis of the vertex (in my case, Y), it should just work like I'm showing in the gif below. Both in 2.83 and 2.90.

Snap2

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hello :). Perhaps I missed something, but shouldn't the vertex end up touching the edge? $\endgroup$ – Jachym Michal Jul 4 at 20:02
  • $\begingroup$ Hi! :) Yeah, that's the part I found a little unclear in the question. However, this requires the local axis of the vertex to intersect with the edge in the first place. If that's the case, it really just works. I'll include it in my answer. $\endgroup$ – michaelh Jul 5 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.