1
$\begingroup$

When I export the scene as glTF 2.0 file format, it exports it with textures, but without any material information like specular-ness. I literally set it to 0 in principled BSDF, but when it's exported as glTF 2.0 .glb file it exports without that material setting.

enter image description here

Above is my node settings in shading tab.

enter image description here

And this is the result, which shows it exported without material information.

Thanks in advance.

**Solved, Thanks!

enter image description here

$\endgroup$
2
$\begingroup$

glTF 2.0's core material system uses the metallic + roughness PBR system. You are correct that the specular channel is not currently included. This may change in a future version of Blender, as there is a newer glTF extension proposal for including it inside of the metal/rough workflow. But it could be some time before that appears in Blender's importer/exporter for glTF.

In the meantime, for this model you may be able to work around this by setting Roughness to 1.0. That should make the material diffuse enough to not show any specular reflection.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.