0
$\begingroup$

im trying to import this glb file containing texture, model and animation.

when i import it into blender (latest), it has this weird hollowed out look. the face is not visible until you appear it from inside.

anyways, hope somebody can help me how to correct render.

here is the glb file https://filebin.net/hwkmdsfpvzlmg5r5/Teisel_Bonne__Cutscene_.glb?t=g2bmzav0

enter image description here

you can see the texture is turned inside out in particular the face is hollow and the face texture can only be visible when rotating the model.how do i fix this?

I played with the normals but it still missing bunch of faces. I used mesh ---> recalculate normals outside.

enter image description here

$\endgroup$
4
  • $\begingroup$ @Timaroberts thx I edited the question to include screenshot. $\endgroup$
    – jamus
    Jul 1, 2020 at 0:59
  • $\begingroup$ Try to recalculate the normals. Also there seems something wrong with your materials... try to remove one by one to figure out the issue. $\endgroup$
    – brockmann
    Jul 1, 2020 at 1:03
  • $\begingroup$ what do you mean by normals? $\endgroup$
    – jamus
    Jul 1, 2020 at 1:33
  • $\begingroup$ en.wikipedia.org/wiki/Normal_(geometry) $\endgroup$
    – brockmann
    Jul 1, 2020 at 1:49

1 Answer 1

1
$\begingroup$

The problem you are having is easily overlooked, and is found in your material settings. You have backface culling turned on, and not all faces are facing the same direction giving you the strange result you are seeing.

enter image description here

Turn off backface culling and this should fix the problem.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .