0
$\begingroup$

enter image description hereMy pc has a

CPU- Ryzen 9 3950X

GPU- Quadro RTX 5000

RAM- 124 GB of G.skill Trident

Motherboard- Giggabite Aorus x57

SSD- Samsung 970 Nvme M.2 1TB

in it. But, when I use the "Grassgwald" add-on, the frame rates in my viewport drop so much, I cannot rotate my model. There is a huge delay. There is a lot of grass in the seen, it is on a large plane depicting about 100x250 square Feet.

I have installed all drivers for my GPU and they are up to date. I have also made sure Blender recognizes the card. Since it is a Quadro RTX card, I have the option to use Optx as well as Qudo Cores in the options menu. I have tried both, neither changes performance.

To be clear, this happens when I am in the "shaded" tab with default settings. It also happens when I am in the "layout" tab with default settings.

I was lead to believe this GPU could handle this kind of load. Does ANYONE have a solution, or is it unrealistic to expect that much from my set up? please help. Thank you

-Alex

$\endgroup$
5
  • $\begingroup$ I'm not familiar with this add-on but it might not be well written or if it is it might be doing some task that is slowing down your computer $\endgroup$ – Yohello 1 Jun 29 '20 at 23:29
  • $\begingroup$ It is a reputible Add-on and paid for. how can I test if that is the case? is there a file i cn download with A LOT of objects in it? $\endgroup$ – Alex Jun 29 '20 at 23:35
  • $\begingroup$ Any computer can be bugged down by very complex scenes. $\endgroup$ – susu Jun 29 '20 at 23:45
  • $\begingroup$ how do you work around this problem? $\endgroup$ – Alex Jun 29 '20 at 23:58
  • $\begingroup$ Simplify the scene, don't have to show all of it all the time, but the element you are workin' on $\endgroup$ – susu Jun 30 '20 at 2:34
0
$\begingroup$

One of the problems with blender right now when using particles system is that it is not easy (or nearly impossible) to make the instances avoid each other and not overlap, and thus cover maximum space.

You Setup is great, I'm thinking that you have too much grass in your scene, probably more than you need to cover the surface. If you show me a screenshot of your scene or your particles settings at least, I can pinpoint (and I will update this answer accordingly).

PS: Also, just a friendly tip, yes Graswald is a good add-on, but do consider checking out Scatter add-on

https://www.blendernation.com/2020/04/03/blender-add-on-spotlight-scatter/

disclaimer: I'm in no way related to devs of either add-ons. So this recommendation is purely professional, unbiased.

$\endgroup$
3
  • $\begingroup$ Hi Ahmad, I have added a screen shot to the original post. also I need these scenes to have a thick coat of grass and there was not too much overlay. $\endgroup$ – Alex Jul 1 '20 at 19:25
  • $\begingroup$ Sorry for getting back late, hadn't logged in for last 2 days. Anyways, the count of grass doesn't seems to be an issue here, it is infact 'below average' of what most people use in a similar size scene with way less powerful setup. $\endgroup$ – Ahmad Bilal Jul 3 '20 at 23:33
  • $\begingroup$ Please try to install 2.83.1 (its a stable version that came out recently, and has many bugfixes.. specially if you are on Mac). Also, try adding those grass without the add on, by creating a new particles system >> set it to hair >> tick advanced below hair text >> under render submenu .. select Object instead of Path >> adjust particles count to 50k, then move up or down to test. Test this and let me know. $\endgroup$ – Ahmad Bilal Jul 3 '20 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.