2
$\begingroup$

I have an object in my scene which is acting as a mask, but i need it to be just a regular object. Here's a gif: enter image description here

It's not just the render view but it also renders in the final image as a mask. This does not happen in eevee, though. Both of the objects have a Principled BSDF material and the object which is acting as a mask DOES NOT have a holdout shader. I also tried going through some of the options in the object properties, but nothing changed.

Here's the blend file:

$\endgroup$
  • $\begingroup$ Hello :). Just to make sure - isn't holdout enabled in Object tab > Visibility? $\endgroup$ – Jachym Michal Jun 29 at 10:30
  • $\begingroup$ No, it wasn't, it's probably something else. I also added the blend file now. @JachymMichal $\endgroup$ – daniela Jun 29 at 20:06
3
$\begingroup$

enter image description hereYou have it as "Shadow Catcher" you need to select the object and go to Object properties > Visibility > Shadow Catcher (uncheck this one)

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks! It finally works now :) $\endgroup$ – daniela Jun 29 at 21:19
  • $\begingroup$ @daniela shadow catcher is not meant for the object to have shadows, but to create an object that is invisible except for the shadows projected by other objects. Shadow catcher is used mostly when you want to composite on top of images. $\endgroup$ – susu Jun 30 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.