2
$\begingroup$

I rendered an image using the Render Regions add-on, and it turned out like this:

enter image description here

Here are my render settings:

enter image description here

Here are my Camera settings:

enter image description here

The first image was rendered using the Render Regions addon, with one row and column.

With Render Regions set to four rows, here is what the top fourth of the image looks like when rendered at %100: enter image description here

Here's what it looks like when rendered at 60 something percent:

enter image description here

As you can see in the picture below, the region margin is as wide as the whole render dimension. Only the top region is selected. I used the Render Regions add-on to render four fourths of the image and the top fourth was rendered last. That picture is there to show you that Render Regions was rendering images as wide as the width of the render dimension.

enter image description here

Because there is a background image being used as the sky, Alpha, under Shading needs to be set to Transparent. I'm using Blender Internal Render.

A little bit of computer info: 128 MB graphics, 3.00 GB RAM; 1 Intel Core 2 Duo processor T2500 2.5 GHz (processor is just a lucky guess).

Link to .blend file

$\endgroup$
1
$\begingroup$

Rendering a region will always have the margins added to it when completed. The purpose of this tool is to make it so you do not have to render an entire image when you are test rendering, so the margins give you an idea of what part of the scene it is in.

If you really need to use this method for a final render (NOT recommended, move your camera!) then you can use any image manipulation software to get the margins trimmed off.

If you want to render different sections because of huge render times for the entire image, and then add them together in post-pro, that works well, too.

HINT: Check transparent background settings, it will make your work a whole lot easier!

Shading Alpha

If this does not answer your question, please leave a comment, I'll try to get back to you.

$\endgroup$
  • $\begingroup$ When I use Render Regions to render any amount of smaller render regions, the output image has the black in it. The entire region is as wide as the camera, only the output image has black in it. And the black is covering up parts of the rendered image. $\endgroup$ – Cyborggeffien Nov 3 '14 at 19:17
  • $\begingroup$ BTW, Blender 2.72 comes with a built in version of this, no addons. It worked excellently when I last tried it. $\endgroup$ – VRM Nov 4 '14 at 2:56
1
$\begingroup$

The Background image being used was 1920 pixels wide times 1600 pixels height. I use the Render Regions addon. I render a scene that is wider than 1920 pixels wide.

The black areas are appearing in the image because the rendered image is wider than 1920 pixels. So rendering at smaller percentage scale will make the black areas smaller. The part of the image that shows what is actually being rendered will be the width (or height if height is taller than background image) of the background image.

This also applies to the height of rendered images and background images.

Vertical black areas will appear if the rendered image is wider than the background image when rendering. Horizontal black areas will appear if the rendered image is taller than the background image when rendering.

So if a rendered image is shorter than 1600 pixels but wider than 1920 pixels, vertical black areas will appear. If a rendered image is taller than 1600 pixels but shorter than 1920 pixels, horizontal black bars will appear in the rendered image. If a rendered image is taller and wider than the width and height of the background image, you will get some black areas in your rendered image.

This applies if you use Render Border, Render Regions addon which is a separate download, or just render an image without any additional features or addons.

For those of who who want a link (I'm not saying anyone wants a link): http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Render/Render_Regions

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.