1
$\begingroup$

As in the title I have the problem with non responsive scultping while I’m working on my T-Rex. The brush is so delayed that I can’t sculpt, sometimes I have to wait like 5 seconds to see the effect, I tried to serach on the web how to resolve the problem but I couldn’t find anything, I will add that I’m not using any modifier and my PC specs are quite good:

  1. CPU Ryzen 3900 12 cores
  2. GPU RTX 2080 Super
  3. RAM 32 Gb 3600 Mhz

(I have the lattest drivers)

Please help me I’m quite newbie, I was searching how to resolve it since yesterday and still nothing :(

enter image description here

$\endgroup$
  • $\begingroup$ Can you upload the .blend so that I can try to reproduce on my end? $\endgroup$ – Cultmethod Jun 28 at 18:54
  • $\begingroup$ @Cultmethod sure, here you go! :) Thanks BTW! drive.google.com/file/d/1_gt0Vnes3OWtwQM4KheMtd07xs4TYY49/… $\endgroup$ – DryEvil Jun 28 at 18:55
  • $\begingroup$ Higher cores don't help if there are operations, that can only run on a single core. There may not be a solution to your problem other than higher single core speed (and hyperthreading etc., but lets leave that out) $\endgroup$ – WhatAMesh Jun 28 at 18:58
  • $\begingroup$ @WhatAMesh I doubt that my single core is such bad to dont rect 1,5 milion poligons, when I see other people sculpting on higher values 50 times higher (like 50 milions), that would mean that their clock speed is 250 Ghz? $\endgroup$ – DryEvil Jun 28 at 19:03
  • $\begingroup$ There are different operations, brush sizes and settings, such as dyntopo that increase or decrease the needed amount of computation. If you have Photoshop for example, open a file, make some art and then drag the smudge tool with large scale accross the image. Won't be smooth, even though it should be a very simple operation. But if you are that defensive to a simple comment maybe you shouldn't ask in the first place $\endgroup$ – WhatAMesh Jun 28 at 19:11
2
$\begingroup$

I opened your file, and sculpting was definitely a little bit laggy, but nowhere near what you're describing (Having to wait 5 seconds before seeing the result of a sculpting change). However I managed to fix the problem by doing the following:

  1. Hide the "Teeth", "Bones", and "Eyes" collections.
  2. Important: Deactivate the Armature modifier from displaying in the viewport.

Sculpt

After I did this performance increased drastically for me.

Hope this helps!

| improve this answer | |
$\endgroup$
  • $\begingroup$ You are a genius man! I love you! :D The problem is solved although it is normal that when I'm trying to use dyntopo with small resolution there are still lags? But without dyntopo works very well. $\endgroup$ – DryEvil Jun 28 at 19:35
  • $\begingroup$ Definitely not a genius, took me awhile to figure out what the hell was going on :) Glad I could help! $\endgroup$ – Cultmethod Jun 28 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.