1
$\begingroup$

I used a boolean modifier with union to add a hand to body, and after doing that and trying to merge them together in sculpt mode, I got holes in my mesh.. I tried to fix this by selecting all by trait - non manifold and then clicking alt + f. that closed the holes.. but also my faces are now green.. I attached a picture. can someone explain to me how to fix this? and if possible how to smoothen the joined areas.

enter image description here

File : http://www.mediafire.com/file/tl2a1p2mnqavpnd/hand.blend/file

Thank you!

$\endgroup$
  • $\begingroup$ I'm assuming you mean boolean modifier not binary? Can you upload the .blend so I can further investigate? $\endgroup$ – Cultmethod Jun 28 at 18:56
  • $\begingroup$ added the file Thanks $\endgroup$ – mike eike Jun 28 at 19:09
  • $\begingroup$ There is a lot of non-manifold parts, switched normals, holes, and overlaping geometry inside. If you have hole body I would suggest "Voxel Remesh" feature. You can test result also on this hand, but use Boolean operation to close (fill) opened shoulder to make it work. $\endgroup$ – vklidu Jun 28 at 19:55
0
$\begingroup$

Here's how I fixed it on my end.

  1. Switch to edit mode and then press 2 for edge selection mode.
  2. Select > All by Trait > Non Manifold
  3. Deselect the open face at the very top of the arm
  4. Press X > Delete Vertices
  5. Select > All by Trait > Non Manifold (Again)
  6. Press F to fill all the remaining holes.
  7. Add a Remesh modifier to the object.
  8. Set Voxel Size to .003 and Adaptivity to 0. Enable smooth shading.
  9. Hit apply on the modifier and continue sculpting without errors. You might need to smooth out some areas after the remesh.

Here are images of these steps:

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.