0
$\begingroup$

I have the latest version of 2.9, a gtx 1060, and 16gb of ram. When I go into "denoising" and check "viewport" with "fastest (optix)" selected it'll take around 7 minutes to load the render kernels. Once it's done the viewport render freezes and gives me this error message that says.

OPTIX_ERROR_CUDA_ERROR in optixDenoiserComputeMemoryResources(denoiser, rect_size.x, rect_size.y, &sizes)(device_optix.cpp850)

I have no idea what it means and I'm mainly posting this just to see if anyone else have this problem, I don't really expect a fix for it. I've reinstalled blender, factory reset it, and updated my gpu driver to no success. Thanks for taking time to read.

$\endgroup$
2
$\begingroup$

With the latest (as of this writing) alpha release of 2.9 you can indeed use optix and take advantage of viewport denoising in cycles with both CPU and certain non RTX GPUs.

From the Cycles release notes

GPU Rendering

  • OptiX support is now enabled on all NVIDIA GPUs that support it, which is Maxwell or higher (GeForce 700, 800, 900, 1000 series).

  • NVLink support for CUDA and OptiX. When enabled in the Cycles device preferences, GPUs connected with an NVLink bridge will share memory to support rendering bigger scenes.

  • NVIDIA GPU rendering on macOS is no longer supported. Apple dropped support for CUDA drivers in macOS 10.14, and no recent Apple hardware uses NVIDIA graphics cards.


Viewport Denoising

Intel OpenImageDenoise is now supported for interactive denoising in the 3D viewport. This works on any recent Intel/AMD CPU (with SSE 4.1).

Previously viewport denoising was only supported for NVIDIA GPUs using OptiX.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I just installed 2.9, I have a 1060 but the optix settings in the preferences is still disabled. Do I need to install some related driver? $\endgroup$ – TheNoob27 Sep 2 at 18:23
  • $\begingroup$ @TheNoob27 I would expect current drivers should work, I use a 1070 without issues in current release. $\endgroup$ – Timaroberts Sep 2 at 19:20
1
$\begingroup$

You need a RTX class GPU to use OptiX. RTX cards include a ray trace (RT) core that this technology depends on. Sorry for the bad news :(

Edit: I am completely incorrect, disregard. Apparently Kepler+ can use OptiX.

| improve this answer | |
$\endgroup$
  • $\begingroup$ But my friends had gotten it to work no problem on there's with the exact same specs on 2.9 because optix now supports cards that aren't an rtx $\endgroup$ – skooka Jun 27 at 21:30
  • $\begingroup$ Hmmm... I did some more digging and it looks like you actually can use OptiX with older generation Nvidia cards. Here's a recent discussion with some solutions that might work for you: devtalk.blender.org/t/blender-2-8-cycles-optix-on-non-rtx-card/… Sorry I can't be of more help. $\endgroup$ – Jay Jun 27 at 22:01
  • $\begingroup$ Thanks for trying to help, still haven't found the solution. $\endgroup$ – skooka Jun 27 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.