0
$\begingroup$

I've been using blender since v2.74, but I'm still a rookie at some of the stuff. I'm using 2.82 now and whenever I use polybuild or even normal selection in edit mode, and try to move the vertices that are front facing I can't do it without accidentally selecting the ones on the other side or back facing - even without xray on. It's a small issue if what I'm doing is a small task, but I'm having a hard time now with my character's retopo... enter image description here

I don't know much, but to work around it I've just been separating faces in edit mode so I can edit each set as separate objects then mirroring and rejoining both sets. But I'm doing the ears now and it's annoying to do all that all over again because it takes a lot of time. I just wish there was a way to remove this feature because it wasn't there in previous versions before 2.8. Is there a way to just limit the selection to the visible/front facing vertices in 2.8? Pls help

$\endgroup$
  • $\begingroup$ Select them in front ortho view. $\endgroup$ – Lukasz-40sth Jun 27 at 9:40
  • $\begingroup$ @Lukasz-40sth I've tried that and it actually works to bypass the issue if the model is symmetrical. But times you need to rotate the object and end up facing the same problem. $\endgroup$ – SoloGamer 112 Jun 28 at 8:05
1
$\begingroup$

There are several approaches you could take.

Note: So far as I can find, the backface culling options don't seem to do the trick. The one in the Materials tab, under the Settings section, would seem to only affect the appearance of backfaces during rendering. But there is another Backface Culling option located under the Viewport Shading menu at the top right of the 3D View, and it is only accessible if you happen to be in Solid shading mode at the moment. Clicking the Backface Culling checkbox here makes the backfaces change to translucent, but doesn't prevent their selection. One could be forgiven for expecting either of these options to prevent selection of backfaces, but neither do. The latter doesn't seem to do anything.

Thankfully, there are other approaches.

  • By default, your objects in a new scene are in solid shade mode. When you go into Edit Mode for any object, it is likewise solid shaded by default. If you go into Wireframe shading mode for the object while it is in Edit Mode, you will see through the object, and be able to select vertices on both sides. But if you press Alt + z, you will toggle the X-ray feature for the mesh. This feature works in both Object Mode and Edit Mode. In Edit Mode, it forces an opaque view of the mesh in wireframe shading mode, where normally, it would be transparent when the wireframe shows. This can help prevent vertex selections to the rear of the mesh.
  • Alternatively, you can press Alt + b at any time and then drag a box to create a View Clipping boundary, which can be used to coral any parts that you want exclusively visible, meaning it instantly hides everything outside the boundary from view. Pressing Alt + b again gets rid of the boundary.
  • Another interesting thing to note: For addressing this kind of issue specifically during dyntopo, there is a common workflow in Blender where one temporarily adds a Solidify modifier to the main mesh. The reason for this is that the Solidify modifier simulates the existence of both an outer shell facing and an inner shell facing, which includes the simulated behavior of face normals. By having a Solidify modifier in place, then when going into Edit Mode, the inner shell on the opposite side of the object behaves as if it were an outer shell instead. This tricks Blender into ignoring those faces during selection, effectively giving you backface culling in Edit Mode even if you can't get it any other way.
| improve this answer | |
$\endgroup$
  • $\begingroup$ I think x-ray is the best solution so far... $\endgroup$ – SoloGamer 112 Jun 28 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.