1
$\begingroup$

I am able to input liquid into the scene from a flow object set as geometry and the liquid falls into a flask that is set as a collision effector.

But when I scale down the flask to its actual size (about 8cm diameter), the fluid particles either disappear altogether, or they appear for the first frame only and then disappear. Plus, the particles are extremely big and are larger than the flask itself.

Can anyone explain how I can work with such a small scale and still get the same results as I would from a larger scale scene? What factors or settings can be adjusted and what is each of their significance? Does adjusting the grid size do anything?

I saw this post: https://blenderartists.org/t/is-there-such-a-thing-as-too-small-of-a-scale-for-mantaflow-flip-fluids-particles-too-big/1208348 but I am still confused. I try changing the particle size and don't see any difference.

My geometry-set flow object is a 0.025x0.025x0.01 cube (see image). Thanks for your help!

UPDATE: Here is the link to the blender file if you want to take a look https://spaces.hightail.com/space/4kpJQiVAFl

enter image description here

$\endgroup$
4
  • $\begingroup$ what is the resolution division of the simulation? did you try to boost it? $\endgroup$
    – Sanbaldo
    Jun 25 '20 at 10:00
  • $\begingroup$ @Sanbaldo I bumped it up to 240 and still no visible fluid particles. I shouldn't do anything with the mesh, right? I figure I need to see the particles before I bake any mesh into it. $\endgroup$
    – w3stpol3
    Jun 25 '20 at 11:14
  • $\begingroup$ Can you share the blend file? $\endgroup$
    – Sanbaldo
    Jun 25 '20 at 11:17
  • $\begingroup$ @Sanbaldo I just edited the post. Thanks for your help! $\endgroup$
    – w3stpol3
    Jun 25 '20 at 20:35
2
$\begingroup$

One thing I note from your file is that you have rescaled the flask but you have not done 'Apply Scale' to apply that new scale to the mesh. This can produce unexpected results from the simulation; you should almost always 'Apply Scale' after rescaling a mesh involved in a simulation.

For small scale simulations you may need to significantly increase the simulation 'Steps Per Second' and 'Iterations' and change the default sensitivity margins appropriate for the new scale and/or the 'Surface Thickness' in the Effector settings.

$\endgroup$
1
$\begingroup$

Blender currently cannot handle simulations when they are that small.

Rigid body needs all object to be at least 1 m at smallest in dimensions.

Same with fluid and most other solvers within blender.


As of now I would suggest increasing it to 10x the size.

$\endgroup$
2
  • $\begingroup$ What are your sources for that statement? It can certainly handle objects much smaller than 1m in my experience - but not with the default settings. Need to significantly increase steps per second and iterations and change the default sensitivity margins appropriately. $\endgroup$ Nov 27 '20 at 9:35
  • $\begingroup$ I tested this myself, and have experienced it a few times $\endgroup$
    – Yohello 1
    Nov 30 '20 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.