At each startup, Blender 2.83 seems to not load the list of recent files. It is not saving User Preferences as well.

I edited a keymap (removed M for measure everywhere) and have to redo it every time I use blender...

I had a previous 2.81 version installed before from where I copied the user prefs.

Any idea what can cause this ?

  • $\begingroup$ Turning the administrator launch option seems to fix it, but this can't be a solution. It was working fine in all my previous install. $\endgroup$ Jun 25, 2020 at 8:00
  • $\begingroup$ If you haven't fixed it by now hope this may help Ctrl u then choose save preferences. $\endgroup$
    – petellgra
    Jul 10, 2020 at 11:21
  • $\begingroup$ Sounds like the permissions nproblem in the OS. If things work as administrator, maybe the issue is that as user you don't have permission to write in the folder where the settings should be saved $\endgroup$
    – no-can-do
    Jul 10, 2020 at 13:35

3 Answers 3


Make you changes in the preferences and go to File > Preferences and at the bottom left hamburger icon choose Save Preferences

enter image description here


Ya, this is a consistent bug in every version of blender but there is a way out!

First open a blend file (which is saved from before or open a general project and save it)

Then, go to preferences and make your changes

Then, close the preference window and go to the render tab in the properties

There, change the render engine to Cycles (if it's already in Eevee) or to Eevee (if it's already in Cycles)

Press Ctrl+S to save

Now close blender and again reopen it to see if your preferences are saved or not :)

Hope it helps! :))


Just download the recent version of Blender only from Microsoft Store. Then open any pre-existing file, make your changes in preferences then save the file. It should work.

  • $\begingroup$ Why the Microsoft store, how does that help solve the issue? $\endgroup$ Nov 12, 2021 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .