0
$\begingroup$

I have a box. (Not really, but this is a minimal example.)

the box

The texture on this box shouldn't be a colour texture, but a data texture (e.g. specularity intensity). The intensity data is in the blue channel of the specularity texture, so I set the texture's RGB Multiply to cut out the other channels.

the RGB Multiply I'm talking about

the box, but blue

I need this to be intensity rather than colour, so I check "RGB to Intensity" and set it to white. (I'm leaving it as affecting colour for illustrative purposes.)

the dark box

I assume it's really dark because most colour systems use red 0.3 green 0.6 blue 0.1 or something like that to convert from colour to greyscale. So, I change the Color Space from sRGB to Non-Color.

the box, as it should not be

There is no effect. I've tried every option in the Color Space dropdown and none of them appear to cause any change at all.

Why does changing the colour space not stop "RGB to Intensity" from doing colour space calculations? How do I correctly tell it to interpret the "from black to blue" texture as "from black to white"?

Additional notes:

  • Blender 2.79b, internal renderer. These are how things must be.
  • I know how to do this with nodes, but this would triple my workload (at minimum).
  • I know how to do this by simply editing the original textures, but this would quadruple my workload, and I'm not supposed to be changing the textures.
  • I tried using the colour ramp, but it flat-out ignores whatver I put in the RGB Multiply boxes.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.