0
$\begingroup$

I'm working on a robot for a video game, and some of the bones act different than the rest. Some move different parts of the mesh with unequal force even though the weight is 1.0 on all affected parts. Another problem is were assigned vertices don't move at all even though they are part of the same mesh and weighted at 1.0.

$\endgroup$
6
  • $\begingroup$ they can be weighted 1 but doesn't mean that another bone has no influence on these vertices. To rig a robot you should use With Empty Groups, then assign the vertices to the groups they are supposed to be part of, this way you're sure no vertex will be part of a group it is not supposed to be part of $\endgroup$
    – moonboots
    Jun 23 '20 at 12:35
  • $\begingroup$ That's what I've done, no the vertices in question are only weighted to one bone/vertex group. $\endgroup$
    – Chipset
    Jun 23 '20 at 12:37
  • $\begingroup$ so maybe share your file: blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    Jun 23 '20 at 12:38
  • $\begingroup$ <img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=BYM5zbAe" /> Here you go, I'm working on the one on the right, Armature.003 and it's child $\endgroup$
    – Chipset
    Jun 23 '20 at 12:45
  • $\begingroup$ so for example for the robot on the right, you need to give some correction to the elbow in Weight Paint mode, for the second robot from the right, the arm objects have not been parented to the arm bones, etc... $\endgroup$
    – moonboots
    Jun 23 '20 at 12:52
0
$\begingroup$

For the shoulder, first select the armature, then shift select the mesh, and switch to Weight Paint mode. Display the right panel with N and choose Blend > Mix, disable Front Faces Only and enable 2D Falloff.

enter image description here

Now select a bone and paint:

enter image description here

For the finger, as it needs a bit more precision, come back to Edit mode, select the vertices, in the Properties panel > Object Data > Vertex Groups, choose the vertex group they are supposed to be part of and click Assign. You can also use this list to remove some vertices from some groups. In the right menu, under + and -, you can sort the vertex groups by name.

enter image description here

$\endgroup$
6
  • $\begingroup$ Shoulder and that finger bone are not supposed to move, so I haven't spent any time on them. The problems i'm facing are with the right elbow and the mid/tip finger bones. $\endgroup$
    – Chipset
    Jun 24 '20 at 12:16
  • $\begingroup$ use the exact same process $\endgroup$
    – moonboots
    Jun 24 '20 at 12:18
  • $\begingroup$ I have, over and over again. With deform it deforms the mesh, which is bad since it's a robot. But without deform it doesn't move at all. Try rotating the FingerMidL1 bone, nothing except the tip moves with it. How do I share images? $\endgroup$
    – Chipset
    Jun 24 '20 at 12:23
  • $\begingroup$ Yes I've just tested, so you need to enable Deform and use the process I explain in the second part, select the vertices that are supposed to move, find the vertex group called FingerMidL1 and click Assign $\endgroup$
    – moonboots
    Jun 24 '20 at 12:38
  • $\begingroup$ I fixed it by creating new empty groups and starting over. Thanks for all the help. $\endgroup$
    – Chipset
    Jun 25 '20 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.