0
$\begingroup$

Here is the first tank model I made. It uses the array and curve modifier for the track shape and I purposely left a gap which I stitched together with the F key function to create a solid shape in Blender. When I placed it in Unity the stitch I made came out as a partial void but the track suspension worked: poggers

Notice the void in the track links where I tried to stitch them together.

enter image description here

And the tracks deform perfectly.

After this I tried to fix this issue by making the number in the array just a bit too small and then I edited the bezier curve to make it just small enough to made the track almost connect. I did not edit this after applying the array and curve modifier.

enter image description here

And the later model looks like this, notice that the track comes out perfectly without any gaps or voids.

But when I try to deform the bone it ends up very broken enter image description here

As you can see the track does not deform properly. In a newer version, I tried arranging the bones better so that the automatic weight painting would look better.

ekp

But the issue is still persistent in Unity:

enter image description here

The model and armature/bones: enter image description here

I have tried creating these tracks several times. Any help would be greatly appreciated.

$\endgroup$
4
  • $\begingroup$ I assume you mean the bars that make up the track become a sort of a staircase instead of a nice continues band. I'm puzzled why the staircase bars don't show in your 2nd image but it seems to me it might help if you check the Merge box on the Array modifier before you apply it. This will connect the bars to each-other and make them one uninterrupted mesh, and should eliminate the stairs effect. (if that's not the issue, I'm sorry to say don't fully understand the description of your problem) $\endgroup$ – Fjoersteller Jun 22 '20 at 2:20
  • $\begingroup$ Can you post a blend file ? $\endgroup$ – 4nof Jun 22 '20 at 2:44
  • $\begingroup$ Thank you @Fjoersteller this method worked but unfortunately when I move the bone for the fourth wheel the start and end of the array detaches itself. What settings should I use to make the loop connect properly? Here is an image of the problem: cdn.discordapp.com/attachments/704413958437863524/… $\endgroup$ – Matt Jun 23 '20 at 5:01
  • $\begingroup$ I made an answer to your question. hope it helps. : ) $\endgroup$ – Fjoersteller Jun 24 '20 at 16:35
0
$\begingroup$

First you can delete the faces on the sides of the track segments, where they connect. These will end up on the inside of the track where you can't see them, so you don't need them.

enter image description here

When you merge your track segments (to get rid of the staircase effect) by checking the Merge box in the Array modifier, you can also check the box First Last to close the loop. It doesn't always work though, like in my example.

enter image description here

But that's not a problem. : )

  1. You can close the loop manually in Edit Mode, after applying the modifiers. Select pairs of vertices than need to be connected and press F. Then use F to make faces between the newly created edges.

  2. Or select al the 8 vertices you want to connect and do Edge > Bridge Edge Loops.

  3. Or you can add a Weld modifier, and increase the distance until the gap is bridged.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.