7
$\begingroup$

Every time I enter sculpt mode, the mesh (which should be grey) is a whole bunch of different colors. I tried changing the metacap, but the stupid colors remain. Any advice would be nice.

Picture bellow:

Image of problem

$\endgroup$
4
  • $\begingroup$ I've encountered this also, recently, in 2.83, and I couldn't find a pattern to explain why it is happening. I went researching it only to find no one talking about it. This leads me to believe it's a fairly new bug. But I don't know for sure. $\endgroup$
    – R-800
    Jun 22, 2020 at 4:55
  • $\begingroup$ Thank you. It's always nice to know I'm not the only one encountering the problem. My best bet is to downgrade to blender 2.82. $\endgroup$ Jun 22, 2020 at 13:26
  • $\begingroup$ It happened to me too after joining different meshes together, a simple remesh fixed it $\endgroup$ Sep 21, 2020 at 16:40
  • 2
    $\begingroup$ Might be something to do with face sets? - A new feature in 2.83 I believe. Check if it's turned on right at the bottom of the Viewport overlays menu. Alternatively, is 'Random' set as the viewport shading Colour? $\endgroup$
    – John Eason
    Sep 21, 2020 at 20:09

1 Answer 1

9
$\begingroup$

I had the same issue for hours in Blender 2.9

It appears everytime I apply boolean modifier on two or more objects or when I join them. My assumption is that it might be because of different face densities.

The solution from John Eason is working for me. Just turn off the Face Sets.

enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ In Blender 2.9 I had to go to sculpt mode, then there is a "Face Sets" menu in the top left corner of the viewport, click it, then hover over "Init Face Sets" then click "By Normals". $\endgroup$
    – ofekp
    Sep 9, 2021 at 23:16
  • $\begingroup$ Thank you! This solved the problem. $\endgroup$ Nov 19, 2021 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .