3
$\begingroup$

I wonder to know if there is a way to dramatically reduce blender slowliness while working on a .blend with lot of objects/particles on a slow PC.

I'm using BI.

I'm looking for more tricks than the usual ones like disabling object visibility, turn them shadeless, send them to other layers/renderlayers, remove shadow casting, you know, all those tricks.

I have 6 to 9 subsurf levels aplied to planes with RGBA video texture, I need to dissolve in particles some dudes for my shortfilm, obviously my PC is so much dying right now. Even reducing the subsurf view level is no good because of the amount of planes being dissolved in particles at the same time.

To buy a new CPU or GPU is not good for me right now.

Ideas? Suggestions? Custom builds for this kind of task? Ubuntu/win8? Dramatic object disabling without deleting them? Other ways to particleize planes with video textures? *Python magic code to disable stuff?

$\endgroup$
  • 1
    $\begingroup$ Are you using the explode modifier? Perhaps using instances might help. It's hard to give suggestions without a .blend to test them though.. Is it possible you could upload it? $\endgroup$ – gandalf3 Oct 30 '14 at 5:43
  • $\begingroup$ Hi Gandalf3. Can you tell me about instances? I have several duplicated planes with lot of subsurf aplied to them individually. The .blend is moddified right now, maybe ill upload it later as I had it before to test it. $\endgroup$ – Fallouturama Oct 30 '14 at 6:14
  • 1
    $\begingroup$ I can't say if instances will work without understanding your use-case better, but I was thinking of things like dupli objects. $\endgroup$ – gandalf3 Oct 30 '14 at 7:50
  • $\begingroup$ Thinking about instances and duplifaces I wonder to know why this situation aplies to me as well: blenderartists.org/forum/… Maybe children use dupliobjects and huge ammount of particles without children as I'm using right now may not, increasing RAM and disk consumption because treats individually each particle data. My .blend has 478Mb. You still want me to upload it? $\endgroup$ – Fallouturama Oct 30 '14 at 15:20
  • 1
    $\begingroup$ If you can find a host which doesn't mind, I'll download it ;) Though try reducing the size a bit. E.g. delete extraneous objects/embedded textures, make sure there is no cached particle system physics, etc. You could also try saving it with compression enabled in user preferences > file. $\endgroup$ – gandalf3 Oct 30 '14 at 17:26
4
$\begingroup$

Expanding on stacker's answer, in case you are not using child particles, you can also reduce the percentage of real particles displayed in the viewport in Particle settings > Display:

enter image description here

Note that you should bake your simulation with this set to 100%, and any simulations with it at less than 100% will not be the same a simulations with it at 100%.

You can also set the particles to draw in the viewport as something other than what they will appear as in the render.

enter image description here

This will probably increase viewport performance a lot

$\endgroup$
  • $\begingroup$ Thnx, but all of this display disablings has been disabled already, even particle--render is disabled because im just using the fragmented plane as particles. And I'm not into baking so far but I think that would only be usefull when rendering, not while working on the physics of my scene. Right? $\endgroup$ – Fallouturama Oct 30 '14 at 15:00
  • 1
    $\begingroup$ @Fallouturama Baking essentially "fixes" the physics by storing all the movements in a cache so that blender doesn't have to calculate the motion of the particles in real time. If you are actively changing physics settings, this of course will not work. It will only really help when playing the animation/changing frames anyway. $\endgroup$ – gandalf3 Oct 30 '14 at 17:20
2
$\begingroup$

You could try to reduce the number of emitted particles in the view. The particle's child section allows you to have different numbers for Display and Render :

enter image description here

$\endgroup$
  • $\begingroup$ Not using children right now but I've used before what you recomend here. Thnx. $\endgroup$ – Fallouturama Oct 30 '14 at 15:02
1
$\begingroup$

Try Shift-H to hide everything but the selected object. This page can be of use for you. http://www.blenderguru.com/articles/11-useful-blender-tricks-you-may-not-know/

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.