1
$\begingroup$

I've been working on a file with Blender 2.7. The file included several materials with textures, that had been mapped on objects using UV maps.

After upgrading to 2.83, all my materials are still there but have no texture associated to them. If I go to the Texture properties panel I can see the textures with a "0" (as if nobody was using them).

I know about the Nodes editor, but I wonder whether I can just use textures. I have to export this model to FBX, and I'm not sure how I would use nodes to map textures on models.

$\endgroup$
1
$\begingroup$

You can have Blender attempt to locate the missing files under the external data section of the File menu. See image below:

FindExternal

If, on the other hand, you need to reconnect the textures manually, you can do so by selecting the material and going to the SHADING tab. From there, if there is no image texture, add one, and connect it as in the image below. This example is a very basic setup for a single image. If your material is PBR and there are other texture maps, add them and connect them to their respective inputs on the Principled BSDF. NOTE - make sure to select a non-color space for Normal, Displacement, Metallic and Roughness maps.

SimpleTextureConnect

| improve this answer | |
$\endgroup$
  • $\begingroup$ But the textures have 0 users! How do I associate a texture to a material, as it did before (2.79)? $\endgroup$ – Simone Jun 20 at 15:22
  • $\begingroup$ Do you still have the files on your computer? If so, I can show you how to restore them. Are they single image textures, or are they full PBR materials? $\endgroup$ – Christopher Bennett Jun 20 at 15:25
  • $\begingroup$ Single image textures. And, lucky for me, the files was versioned and I still have the 2.79 file. $\endgroup$ – Simone Jun 20 at 15:48
  • $\begingroup$ I edited my answer to include the connection for the files. Alternatively, since you have the 2.79 file, you could always try going to File > External Data > Pack All Into Blend, save it and try opening again with 2.8+ $\endgroup$ – Christopher Bennett Jun 20 at 15:51
  • $\begingroup$ Still nothing. I set the image as Base Color of my material, I have the UV map (so the migration didn't lose it), but I can't let the texture show. I'm seriously thinking of going back to 2.79 for this project only. I need to export to FBX, and I've heard bad things about node materials not being exported. $\endgroup$ – Simone Jun 20 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.