2
$\begingroup$

I have created an animal-skull-like mesh in Blender.

In Blender, forward is negative Y.

This is what it looks like in Blender:

enter image description here

And this is what it looks like when I import the .blend file in Unity:

enter image description here

As one can see, the model appears upside down in Unity.

Once dragged into the scene, the model is rotated -90, 0, 0. I guess this is some "hack" that Unity automatically applies to make it look well-oriented.

I have read about this problem, and the problem seems to be that Y is not up in Blender.

While it now looks correct, the rotation gives me headaches as I'm doing some calculations with it, and I expect a rotation of 0, 0, 0 by default.

I know that many people suggest to simply put the mesh into a container and work with the container only, but I would like to avoid this if possible.

I would like to ask if there is perhaps a special export option (for example for .dae format) that would make the model appear perfectly normally oriented in Unity without any rotation tweaks.

Thank you!

$\endgroup$
3
$\begingroup$

Most file export formats allow you to configure some kind of world orientation in the export settings. As you can see in the images below. .FBX, .DAE, .OBJ, and .PLY allow you to specify a "forward" and an "up" axis, and others like .GLTF have a checkbox to specify Y-UP. See below (examples are from .fbx and .dae):

FBX

DAE

$\endgroup$
2
  • $\begingroup$ Thank you! I have used "-Z Forward", "Y Up" and "Apply Global Orientation", and it looks as expected in Unity. $\endgroup$
    – tmighty
    Jun 20 '20 at 14:11
  • $\begingroup$ Glad to hear you got it working! $\endgroup$ Jun 20 '20 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.