0
$\begingroup$

I originally asked this question on Quixel's support forum, but the answer just said "What you're missing is conflating UVs with subdivisions. UVs are independent of subdivisions. You'll need to edit your UV mapping for this plane instead of editing its subdivisions." When I asked if he could elaborate on that, I never got a response. So I figured I'd come to the pros.

My understanding after watching tutorials and trying my best to follow them is this: I make a mesh, if I want detail on this mesh, I need high verts/faces. I then UV Map the mesh with those faces, and this gives me the detail for my textures and materials.

I've added a pic of the road I made to show the issue I'm having. 1k faces is a bit much in my opinion but I wanted to vertex paint so I needed enough verts to accomplish that.

When I drag and drop my materials to the mesh in UE4(and even in Quixel/Substance apps) it looks awful.

What am I missing about my UVs and what am I doing wrong? I follow the tutorials step by step, and they're not doing anything that I haven't done.

Here is my Quixel question as well:

No matter how many verts and faces I have, when i add Quixel or Substance materials to my meshes which have UV maps, I get one very stretched tile. If I bump up to 6 in tiling, it does less stretching, but looks awful.

If i scale the mesh in Y in UE4, I can get it small and it looks okay, but then I would have to be tiling in the same asset over and over, and for performance that is bad.

I've went from 2K to 4K, same issue. I'm using a Blended Material with 3 megascans assets.enter image description here

$\endgroup$
4
  • $\begingroup$ As you can see from your own image, the shape of your selection on the mesh is a rectangle shape, and the one on the UV map is square. True, it is good to use as much UV space as possible, so you can scale it, but do it while keeping the same scale ratio (ie: don't scale on only X or Y, scale both together.) The image above suggests you stretched the UV "island" on one axis only. $\endgroup$ – Christopher Bennett Jun 20 '20 at 0:20
  • $\begingroup$ Well, what I did is just did the Smart UV Project, and I set my island margin to like .06 and that's what it came up with. I think this is probably where my disconnect is. Even if I do Unwrap, it more or less get the same type of outcome. Should I be editing them any further than this? $\endgroup$ – Dresyn Jun 20 '20 at 0:35
  • $\begingroup$ For example, I was attempting to follow this tutorial with the Quixel team on vertex painting. He had created a mesh, which is much larger than mine and likely has more faces and different shapes, and he just drags and drops and it works. You can see at 2:46 youtube.com/watch?v=kJuiSERx_AI So, I figured, make a plane, elongate it, subdivide for more verts, uv unwrap-- presto? $\endgroup$ – Dresyn Jun 20 '20 at 0:40
  • $\begingroup$ I've seen people utilize stacking UVs. Do I need to be using large UVs in my UV Editor and stacking them perhaps? A row of 4 maybe and stack them on top of eachother? $\endgroup$ – Dresyn Jun 20 '20 at 0:44
1
$\begingroup$

Ok, here's what you have to do. Get rid of the existing UV map. Go to object properties, UV maps, select the map and click the minus button. See below:

UvDelete

Then, go to object mode, press ctrl + A and select apply scale. Then, go back to edit mode smart unwrap again, but make sure to untick the "stretch to bounds box.

enter image description here

You should be good to go from there.

However, since all you're unwrapping is a flat plane, you should be fine to just use "unwrap" instead of "smart unwrap". You will still need to remove the existing map though, as smart unwraps tend to "stick around".

EDIT - Here is a .blend file showing what the UV unwrap should look like to avoid stretching, as well as the node setup for both the image texture and the generated one. I hope this helps to clarify that the ability to texture has nothing to do with subdivisions (in most cases). If you want the image tiled, look at the scale section of the Mapping node.

Here is the file -

$\endgroup$
6
  • $\begingroup$ will definitely try this approach, thank you $\endgroup$ – Dresyn Jun 20 '20 at 0:58
  • $\begingroup$ no go unfortunately. tried this with both unwrap and smart on two separate meshes so there weren't any left over UVs on the second try $\endgroup$ – Dresyn Jun 29 '20 at 20:50
  • $\begingroup$ Hi. Sorry it didn't work for you. Unfortunately I don't have time to take another look right at this moment. I promise to come back later and take a look. In the meantime, try reading this guide - it helped me a lot when I was first learning about texture mapping. Guide is here - artisticrender.com/… $\endgroup$ – Christopher Bennett Jun 29 '20 at 21:22
  • $\begingroup$ Thanks for the link. While reading it, I did see what I've been holding off on, especially because I just wanted to work with primitives.. but maybe seams? It may just be a long plane, but with so many faces and vertices, doesn't it make sense? I did put a big long seam down the middle-- and while the result wasn't perfect, they were nearly as stretched. I'll tinker around with it more tomorrow. Thinking of putting seams at the ends of each end of the plane and one down the middle. $\endgroup$ – Dresyn Jun 30 '20 at 7:05
  • $\begingroup$ I really don't think it has to be as complicated as that. Really, all I think you have to do is unwrap the whole mesh and then apply your texture to the a selected area (if that's what you're trying to do). I'll upload a .blend file and add it to my answer so you can see for yourself. $\endgroup$ – Christopher Bennett Jun 30 '20 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.