1
$\begingroup$

I have my fluid simulation beneath a floor plane, and I only want the splashes that rise above the plane to be visible in the final render. I've been trying to find a way to make the pool of fluid below the plane invisible, but applying a boolean to the domain didn't work. I don't think an outflow object would work either, as I do need the fluid to be there in order for it to splash.

Is there any method out there for doing this?

$\endgroup$
  • $\begingroup$ If I understood Boolean should work, tested here blender.stackexchange.com/questions/176612/… probably you should post your simplified blend via blend-exchange.giantcowfilms.com so we can check $\endgroup$ – vklidu Jun 18 at 6:15
  • $\begingroup$ Thanks for confirming that is the right method. I'm going to take a look at that thread and see if I can figure out what step I missed. I'll post back $\endgroup$ – Tyrannosaur Jun 19 at 0:10
  • $\begingroup$ So it does in fact work using a boolean, but not if the fluid mesh has been converted to particles. I thought this was the accepted practice for fluid sims but I'm assuming there's also a way to texture your fluid without going the particle route. I'm going to look into it $\endgroup$ – Tyrannosaur Jun 19 at 0:51
  • $\begingroup$ What? I don't understand your comment and probably for that I don't see a relationship to your original question. $\endgroup$ – vklidu Jun 20 at 5:57
  • $\begingroup$ I meant when you go into the particle settings for the fluid sim and by default it is set to "Halo" which as I understood it would not render. So I set this to "collection", where I have several UV spheres with the material I want. Using this setting,t eh boolean did not seem to work. $\endgroup$ – Tyrannosaur Jun 21 at 6:08
3
$\begingroup$

In case of Particles System type Fluid, there is not a direct way to hide part of particles. You would have to convert sim to mesh.

In this example I used Metaball as particle (because Icosphere object keeps particle system after export).

  • export into Alembic format
  • import back and use Boolean Modifier

enter image description here enter image description here

EDIT

OK I got it, you mean particles generated by Fluid Simulation (Mantaflow) - Liquid and Spray.

enter image description here

Yes, particles are not affected by Boolean Modifier. enter image description here

So there does not exist a way to hide a part of released particles. So only way I know is to use Mball as particle and export-import it as Alembic and use Boolean. enter image description here


Note: In theory - to exclude some particles from render you can influent particles size by Texture, so classic particle system can do this, but fluid sim particles doesnt have such feature.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.